Ask Your Question
0

Navigation Package unable to build from source

asked 2018-07-15 10:04:32 -0600

MandeepSingh gravatar image

updated 2018-07-15 10:41:45 -0600

jayess gravatar image

Hello All,

I am trying to build navigation package but it is giving me this error. Please help.

make[2]: *** No rule to make target '/usr/lib/libpcl_common.so', needed by '/home/mandeep/catkin_ws/devel/lib/libcostmap_2d.so'.  Stop.
CMakeFiles/Makefile2:16363: recipe for target 'navigation/costmap_2d/CMakeFiles/costmap_2d.dir/all' failed
make[1]: *** [navigation/costmap_2d/CMakeFiles/costmap_2d.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 87%] Built target rviz_default_plugin
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
Invoking "make -j4 -l4" failed
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-15 21:31:48 -0600

MandeepSingh gravatar image

I have solved it. The issue was that my libpcl_common was not present in /usr/lib/ but it was there in /usr/lib/x86_64-linux-gnu. I don't know what does that mean. I simply copy psted all the missing libpcl_* files to /usr/lib folder and solved.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-15 10:04:32 -0600

Seen: 68 times

Last updated: Jul 15 '18