Failed to compute odometry pose

asked 2018-07-13 05:07:49 -0500

ryuzaki gravatar image

Hi, i'm trying to use nav2d package to make autonomous exploration with a turtlebot3 burger. When i roslaunch my robot, before starting mapping and exploration, rviz says that no map is received and trying to debug with rqt_console i've found this warnings/errors:

Failed to compute odometry pose, skipping scan (Lookup would require extrapolation into the past. Requested time 1455208818.863310001 but the earliest data is at time 1531473492.888660568, when looking up transform from frame [base_scan] to frame [offset])

and:

Costmap2DROS transform timeout. Current time: 1531473499.6759, global_pose stamp: 1455208815.6299, tolerance: 0.3000

I haven't found a solution through other questions on this forum, i have a problem with sync time i suppose, but even if i tried to change something( clicking on reset like is said here link text or setting true on sim_time), nothing changed and i don't understand how to solve this problem. On this question link text was suggested to use this command`

$ sudo ntpdate ntp.ubuntu.com

but it says that no suitable server for synchronization is found.

Thanks for help!!

`

edit retag flag offensive close merge delete

Comments

Do you have a working internet connection from both computer?

Humpelstilzchen gravatar imageHumpelstilzchen ( 2018-07-13 07:18:31 -0500 )edit

no, computers are connected through a router, without internet connection. Could it be that the problem? If yes, could you explain me why? Thanks!!

ryuzaki gravatar imageryuzaki ( 2018-07-13 08:02:10 -0500 )edit

If you want to reach the internet ntp server at ubuntu.com you need internet, yes.

Humpelstilzchen gravatar imageHumpelstilzchen ( 2018-07-13 10:52:17 -0500 )edit

wait, maybe i don't know well how it works, do i need internet on both computers to use the ntp server? Because the computer i've launched the command on had internet access, but the robot hasn't internet connection

ryuzaki gravatar imageryuzaki ( 2018-07-14 08:57:37 -0500 )edit

however, just to update, i've connected everything to internet, nothing changed, i've tried to launch the ntp command on both machines, but the error is still there. I've looked for a solution and i've found some references about chrony, but i don't really know if that could be the solution

ryuzaki gravatar imageryuzaki ( 2018-07-19 07:46:42 -0500 )edit

Which error is still there? The ntp error? You need to fix that one first.

Humpelstilzchen gravatar imageHumpelstilzchen ( 2018-07-19 08:39:37 -0500 )edit