Ask Your Question
0

Velocity doesn't increase when using Move Base Navigation

asked 2018-07-12 22:39:26 -0600

MandeepSingh gravatar image

updated 2018-07-18 02:19:56 -0600

jayess gravatar image

I am using DWAPlanner for local path planning, when i give a goal to my bot either using 2D Nav Goal from rviz or pubishing to move_base_simple.goal topic the robot moves very slowly. Even thought the velocity limits are set to 3m/s in DWAplanner parameters in local_planner.yaml file, the max veloicty that it reaches is 0.5m/s. If I decrease the controller frequency to 1 only then it is able to reach the max velocity.

Also the acceleration limits are high as well, but the robot seems to never use its max acceleration.

I am unsure whats the logic behind it. Does anyone has any idea?

MY local_params.yaml looks like this

recovery_behaviour_enabled: false

DWAPlannerROS:
  # acc_lim_x: 1.9
  # acc_lim_y: 0
  # acc_lim_theta: 0.63

  controller_frequency: 20.0

  acc_lim_x: 10.0
  acc_lim_trans: 10.0
  acc_lim_y: 0.0
  acc_lim_theta: 2.0

  max_vel_x: 3
  min_vel_x: 0.0
  max_vel_y: 0.0
  min_vel_y: 0.0

  max_trans_vel: 3
  min_trans_vel: 0.1
  max_rot_vel: 2.0
  min_rot_vel: 0.1

  yaw_goal_tolerance: 0.1
  xy_goal_tolerance: 0.1
  latch_xy_goal_tolerance: false

  sim_time: 2.0
  sim_granularity: 0.5
  angular_sim_granularity: 0.05
  vx_samples: 20
  vy_samples: 0
  vtheta_samples: 40

  penalize_negative_x: true
  path_distance_bias: 32.0
  goal_distance_bias: 24.0
  occdist_scale: 0.2
  forward_point_distance: 0.4
  stop_time_buffer: 0.2
  scaling_speed: 1
  max_scaling_factor: 1

  oscillation_reset_dist: 1.0
  oscillation_reset_angle: 1.0

  prune_plan: true
  use_dwa: true
edit retag flag offensive close merge delete

Comments

do you get warning about missing update loop? try setting min_velocity a bit higher, also add

<rosparam command="delete" param="move_base" />

outside your move_base node and then try.

Choco93 gravatar imageChoco93 ( 2018-07-13 01:37:39 -0600 )edit

In the navigation repo I figured out it has something to do with the line 107. My vel is limited by acc*sim_time (10x0.05) as my controller freq is 20Hz.

MandeepSingh gravatar imageMandeepSingh ( 2018-07-13 02:47:52 -0600 )edit

Yes you got that part right, but sim_time comes from dwa_planner , look at section 2.2.3.

Choco93 gravatar imageChoco93 ( 2018-07-13 02:57:23 -0600 )edit

Since I am using dwa sim_period will be considered which is inverse of controller frequency.

MandeepSingh gravatar imageMandeepSingh ( 2018-07-13 04:22:05 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-18 01:34:30 -0600

MandeepSingh gravatar image

For the solution I have just made acc_limits false in my control.yaml for my robot base controller. As I figured that dwa-planner gave appropriate results but it was the base controller which was not achieving the desired velocity given by cmd_vel.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-12 22:39:26 -0600

Seen: 120 times

Last updated: Jul 18 '18