Rviz is not working with my clearpath Jackal

asked 2018-07-11 09:30:41 -0600

dkrivet gravatar image

I have connected my jackal robot to the wifi network and I am able to ssh to the jackal in terminal. However, when I run roslaunch jackal_viz view_robot.launch on my laptop the RobotModel gives an error status saying no transform from [base_link] to [odom]. However when I run rostopic list on the jackal there is the topic /tf so I am not sure where I am going wrong.

edit retag flag offensive close merge delete

Comments

how are you running jackal_viz on your laptop? I am assuming you have followed these instructions to source your window jackal_network

Choco93 gravatar imageChoco93 ( 2018-07-12 08:32:46 -0600 )edit

Yes I have followed those instructions, and I have figured out the problem now. In my remote-jackal.sh file I had got the hostname of my particular jackal wrong. I have fixed it and it is working as expected now

dkrivet gravatar imagedkrivet ( 2018-07-12 08:35:43 -0600 )edit
1

It's better to use static ip's so that when you reconnect you don't get a new ip and don't have to change that into .sh or hosts file.

Choco93 gravatar imageChoco93 ( 2018-07-12 09:03:04 -0600 )edit

I have done that now and it seems to be working smoothly. Thanks for the help!

dkrivet gravatar imagedkrivet ( 2018-07-12 09:04:49 -0600 )edit