Ask Your Question
1

robot model does not appear in rviz melodic

asked 2018-07-04 06:54:13 -0600

tik0 gravatar image

I try to bring my robot model (which I have developed for kinetic) to work under melodic. Everything works so far (despite some plugin issues where I have already committed a pull request), but not the visualization of the robot model. The xacro description of the robot is here.

rviz visualization under melodic: rviz visualization under melodic

rviz visualization under kinetic: rviz visualization under kinetic

Here are some points which I have investigated already:

  • I've checked the model on the parameter server via rosparam get /amiro1/robot_description under kinetic and melodic and they are identical.
  • The dae model is also valid, because rviz complains when I just manipulate the mesh location.
  • The wired thing is, that the hokuyo dae mesh is visualized under melodic.
  • I also check all rviz debug messages via rqt_logger_level and rviz tells me that the URDF description is loaded correctly.
  • Maybe it is realted to this issue but again, the hokuyo dae is shown, but not my robot.

If one would like to test it, follow these steps:

  1. checkout https://github.com/tik0/amiro_robot.git
  2. checkout https://github.com/tik0/amiro_msgs.git
  3. build and run roslaunch amiro_gazebo amiro_simple_world.launch

Can anyone help me with this issue?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
6

answered 2018-07-09 16:46:42 -0600

dhood gravatar image

Other rviz users have encountered a similar issue at https://github.com/ros-visualization/... . The solution may be related to your locales.

If that's the underlying issue, modifying the following environment variable will fix it for you:

export LC_NUMERIC="en_US.UTF-8".

edit flag offensive delete link more

Comments

Setting this variable solved the issue indeed, thanks.

tik0 gravatar image tik0  ( 2018-08-28 06:02:33 -0600 )edit

that worked, thx If you want to make it in system;

echo 'LC_NUMERIC="en_US.UTF-8"' | sudo tee -a /etc/default/locale

girayuzun gravatar image girayuzun  ( 2019-10-25 14:56:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-04 06:54:13 -0600

Seen: 2,649 times

Last updated: Jul 09 '18