ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Help with rplidar sdk installation and port error on ubuntu 16.10

asked 2018-07-03 00:11:33 -0500 gravatar image

updated 2018-07-09 23:37:11 -0500

jayess gravatar image

Hello I'm a beginner on the ROS and linux world

I'm using a rplidar to get the laser map, however after the installation instruction from ROS kinetic tutorial I'm getting an error when after writing the command

roslaunch rplidar_ros view_rplidar.lanuch

it gives me this error

Error,cannot bind to the specfifed serial port/dev/ttyUSB0

Then, I thought I had to download the driver which the SDK zip file from the rplidar website After that, when I go to my downloads directory

cd downloads ls

it show that I have the zip file

and now I'm stuck, I don't how to unzip this file

I have tried this but it did not work


Also, I tried to look online for the port issue, but did not found a solution I tried the

ultra_simple /dev/ttyUSB0

and also

chmod /dev/ttyUSB0

but none of them work

Sorry for the bad explanation but I'm kinda lost

Thank you


After using ls /dev when the lidar is connected , here is what i get

hamzh@hamzh-VirtualBox:~$ ls /dev/
autofs           loop4               stderr  tty35  tty8       ttyS8
block            loop5               stdin   tty36  tty9       ttyS9
bsg              loop6               stdout  tty37  ttyprintk  uhid
btrfs-control    loop7               tty     tty38  ttyS0      uinput
bus              loop-control        tty0    tty39  ttyS1      urandom
cdrom            mapper              tty1    tty4   ttyS10     userio
char             mcelog              tty10   tty40  ttyS11     vboxguest
console          mem                 tty11   tty41  ttyS12     vboxuser
core             memory_bandwidth    tty12   tty42  ttyS13     vcs
cpu_dma_latency  mqueue              tty13   tty43  ttyS14     vcs1
cuse             net                 tty14   tty44  ttyS15     vcs2
disk             network_latency     tty15   tty45  ttyS16     vcs3
dri              network_throughput  tty16   tty46  ttyS17     vcs4
dvd              null                tty17   tty47  ttyS18     vcs5
ecryptfs         port                tty18   tty48  ttyS19     vcs6
fb0              ppp                 tty19   tty49  ttyS2      vcs7
fd               psaux               tty2    tty5   ttyS20     vcsa
full             ptmx                tty20   tty50  ttyS21     vcsa1
fuse             pts                 tty21   tty51  ttyS22     vcsa2
hidraw0          random              tty22   tty52  ttyS23     vcsa3
hpet             rfkill              tty23   tty53  ttyS24     vcsa4
hugepages        rtc                 tty24   tty54  ttyS25     vcsa5
hwrng            rtc0                tty25   tty55  ttyS26     vcsa6
i2c-0            sda                 tty26   tty56  ttyS27     vcsa7
initctl          sda1                tty27   tty57  ttyS28     vfio
input            sda2                tty28   tty58  ttyS29     vga_arbiter
kmsg             sda5                tty29   tty59  ttyS3      vhci
lightnvm         sg0                 tty3    tty6   ttyS30     vhost-net
log              sg1                 tty30   tty60  ttyS31     vhost-vsock
loop0            shm                 tty31   tty61  ttyS4      zero
loop1            snapshot            tty32   tty62  ttyS5
loop2            snd                 tty33   tty63  ttyS6
loop3            sr0                 tty34   tty7   ttyS7

When the lidar is not connected, here is what I get

autofs           full       loop5               pts       stdout  tty22  tty38  tty53      ttyS1   ttyS25   userio     vcsa6
block            fuse       loop6               random    tty     tty23  tty39  tty54      ttyS10  ttyS26   vboxguest  vcsa7
bsg              hidraw0    loop7               rfkill    tty0    tty24  tty4   tty55      ttyS11  ttyS27   vboxuser   vfio
btrfs-control    hpet       loop-control        rtc       tty1    tty25  tty40  tty56      ttyS12  ttyS28   vcs        vga_arbiter
bus              hugepages  mapper              rtc0      tty10   tty26  tty41  tty57      ttyS13  ttyS29   vcs1       vhci
cdrom            hwrng      mcelog              sda       tty11   tty27  tty42  tty58      ttyS14  ttyS3    vcs2       vhost-net
char             i2c-0      mem                 sda1      tty12   tty28  tty43  tty59      ttyS15  ttyS30   vcs3       vhost-vsock
console          initctl    memory_bandwidth    sda2      tty13   tty29  tty44  tty6       ttyS16  ttyS31   vcs4       zero
core             input      mqueue              sda5      tty14   tty3   tty45 ...
edit retag flag offensive close merge delete


Have you checked that the lidar is indeed connected to /dev/ttyUSB0 ?

Delb gravatar image Delb  ( 2018-07-03 02:06:30 -0500 )edit

How do I do that ? I checked ls/dev

and ttyUSB0 is not on the list gravatar image  ( 2018-07-03 02:09:01 -0500 )edit

Yes ls /dev/ is how you do it and if you don't have ttyUSB0 in the list when your Lidar is connected then the issue is normal. Have you another ttyUSB in the list ? If so then change within the launch file ttyUSB0 to your ttyUSB.

Delb gravatar image Delb  ( 2018-07-03 02:20:19 -0500 )edit

If you have mutliples ttyUSB then check ls /dev/ with the lidar deconnected, then connected to see which one is missing between the two tests

Delb gravatar image Delb  ( 2018-07-03 02:21:36 -0500 )edit

I don't have any ttyUSB when I check ls /dev/ gravatar image  ( 2018-07-03 02:24:13 -0500 )edit

With your Lidar connected ?

Delb gravatar image Delb  ( 2018-07-03 02:25:17 -0500 )edit

Yes, I'm not sure if I need to unzip the drive ? gravatar image  ( 2018-07-03 02:26:56 -0500 )edit

Normally no but it's weird that you don't have any ttyUSB, can you edit your question and post the result of ls /dev/ when the lidar is connected and then deconnected ?

Delb gravatar image Delb  ( 2018-07-03 02:31:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2019-07-16 05:59:47 -0500

parzival gravatar image

I had the same error. For me, changing the USB wire worked. Yep, it was that simple for me

edit flag offensive delete link more

answered 2021-07-30 09:27:21 -0500

CLDer gravatar image

updated 2021-07-30 09:28:29 -0500

The following worked for me: sudo adduser $USER dialout

Solution found here.

edit flag offensive delete link more

Question Tools


Asked: 2018-07-03 00:11:33 -0500

Seen: 2,046 times

Last updated: Jul 30 '21