Ask Your Question
0

robotino_drivers building errors

asked 2012-03-09 04:49:22 -0600

rmznrkn gravatar image

updated 2012-03-09 05:18:35 -0600

mjcarroll gravatar image

While I am building the robotino_drivers, I get the following error message. How can I fix this problem?

mkdir -p bin
cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
/opt/ros/electric/stacks/common/actionlib
CMake Error at CMakeLists.txt:43 (include):
  include could not find load file:

    /opt/ros/electric/stacks/common/actionlib/cmake/actionbuild.cmake


CMake Error at CMakeLists.txt:44 (genaction):
  Unknown CMake command "genaction".


-- Configuring incomplete, errors occurred!
make: *** [all] Error 1
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2012-03-12 05:10:39 -0600

Hozefa Indorewala gravatar image

robotino_drivers was an old stack is no longer supported. I would recommend you to try out the new robotino stack. The new stack is based on the new RobotinoAPI2 which is more efficient and is packed with new features. The API2 is currently undergoing its final stages of development but you can already install it on your Robotino.

If you have more questions regarding the RobotinoAPI2 then please post them on the openrobotino forum.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-03-09 04:49:22 -0600

Seen: 183 times

Last updated: Mar 12 '12