Cannot run offboard node for mavros !

asked 2018-06-17 09:59:22 -0600

zubair gravatar image

updated 2018-06-17 13:55:19 -0600

Hi all I am running a mavros_posix_sitl.launch https://dev.px4.io/en/simulation/ros_... , and i have also created a package for an off board example for my drone (IRIS). i am able to run the node but itseens to have no connection with my gazebo. In my node i am already arming my copter and giving various info. The code can be found here : https://pastebin.com/mYP7QyS3 Please help me on what i am missing out here.

something missing :

ommands file: /home/zubair/Firmware/posix-configs/SITL/init/ekf2/iris
ERROR [Unknown] Error creating symlink /home/zubair/Firmware/ROMFS -> /home/zubair/.ros/ROMFS
Restoring terminal
process[gazebo-2]: started with pid [31245]
process[gazebo_gui-3]: started with pid [31250]
process[vehicle_spawn_zubair_HP_Pavilion_Notebook_31226_4351444113664537272-4]: started with pid [31255]
process[mavros-5]: started with pid [31256]
[sitl-1] process has died [pid 31244, exit code 255, cmd /home/zubair/Firmware/build/posix_sitl_default/px4 /home/zubair/Firmware /home/zubair/Firmware/posix-configs/SITL/init/ekf2/iris __name:=sitl __log:=/home/zubair/.ros/log/ca4c3f4e-721d-11e8-afa0-10f00557463a/sitl-1.log].
log file: /home/zubair/.ros/log/ca4c3f4e-721d-11e8-afa0-10f00557463a/sitl-1.log*
[ INFO] [1529236417.862022587]: FCU URL: udp://:14540@localhost:14557
[ INFO] [1529236417.865220370]: udp0: Bind address: 0.0.0.0:14540
[ INFO] [1529236417.865565054]: udp0: Remote address: 127.0.0.1:14557
[ INFO] [1529236417.866007418]: GCS bridge disabled
[ INFO] [1529236417.888115329]: Plugin 3dr_radio loaded
[ INFO] [1529236417.891666636]: Plugin 3dr_radio initialized

Thanks

edit retag flag offensive close merge delete

Comments

Make sure you have setup your environment correctly as given in the instructions here. Also, see the commands I have used in this. They worked for me.

akshayk07 gravatar imageakshayk07 ( 2018-06-17 13:00:06 -0600 )edit

@akshay07, now if i am launching the same mavros_posix_sitl.launch , its showing "process[mavros-6]: started with pid [3098]" although after running my offboard node, its not getting armed

zubair gravatar imagezubair ( 2018-06-17 13:26:36 -0600 )edit

Try launching your Gazebo simulation and MAVROS node separately.

akshayk07 gravatar imageakshayk07 ( 2018-06-17 13:27:51 -0600 )edit

@akshay07 this time i tried just px4 posix_sitl.launch and roslaunch mavros px4.launch fcu_url:="udp://:14540@127.0.0.1:14557" separately. And in another terminal roarun mav mav (where i have my offboard node) and its not receiving any commands

zubair gravatar imagezubair ( 2018-06-17 13:34:06 -0600 )edit

header: seq: 0 stamp: secs: 80 nsecs: 884000000 frame_id: '' connected: False armed: False guided: False mode: '' system_status: 0 ---

This is how my echo looks like, (rostopic echo /mavros/state)

zubair gravatar imagezubair ( 2018-06-17 13:38:55 -0600 )edit