Ask Your Question
1

moveit: param server is missing planner configurations

asked 2018-06-14 11:49:21 -0500

nquattro gravatar image

updated 2018-06-19 10:30:38 -0500

gvdhoorn gravatar image

Hello all, here are the errors,

[ERROR] [1528993777.322079817]: Could not find the planner configuration 'RRTConneckConfigDefault' on the param server
[ERROR] [1528993777.326028820]: Could not find the planner configuration 'SBLkConfigDefault' on the param server
[ERROR] [1528993777.326619022]: Could not find the planner configuration 'ESTkConfigDefault' on the param server
[ERROR] [1528993777.327209350]: Could not find the planner configuration 'LBKPIECEkConfigDefault' on the param server
[ERROR] [1528993777.327770784]: Could not find the planner configuration 'BKPIECEkConfigDefault' on the param server
[ERROR] [1528993777.328322494]: Could not find the planner configuration 'KPIECEkConfigDefault' on the param server
[ERROR] [1528993777.328897858]: Could not find the planner configuration 'RRTkConfigDefault' on the param server
[ERROR] [1528993777.329486582]: Could not find the planner configuration 'RRTConnectkConfigDefault' on the param server
[ERROR] [1528993777.330046872]: Could not find the planner configuration 'RRTstarkConfigDefault' on the param server
[ERROR] [1528993777.330620285]: Could not find the planner configuration 'TRRTkConfigDefault' on the param server
[ERROR] [1528993777.331185690]: Could not find the planner configuration 'PRMkConfigDefault' on the param server
[ERROR] [1528993777.331821514]: Could not find the planner configuration 'PRMstarkConfigDefault' on the param server
[ERROR] [1528993777.332365152]: Could not find the planner configuration 'FMTkConfigDefault' on the param server
[ERROR] [1528993777.332903057]: Could not find the planner configuration 'BFMTkConfigDefault' on the param server
[ERROR] [1528993777.333557242]: Could not find the planner configuration 'PDSTkConfigDefault' on the param server
[ERROR] [1528993777.334391734]: Could not find the planner configuration 'STRIDEkConfigDefault' on the param server
[ERROR] [1528993777.335209338]: Could not find the planner configuration 'BiTRRTkConfigDefault' on the param server
[ERROR] [1528993777.337834268]: Could not find the planner configuration 'LBTRRTkConfigDefault' on the param server
[ERROR] [1528993777.340810491]: Could not find the planner configuration 'BiESTkConfigDefault' on the param server
[ERROR] [1528993777.343505094]: Could not find the planner configuration 'ProjESTkConfigDefault' on the param server
[ERROR] [1528993777.344906710]: Could not find the planner configuration 'LazyPRMkConfigDefault' on the param server
[ERROR] [1528993777.346300595]: Could not find the planner configuration 'LazyPRMstarkConfigDefault' on the param server
[ERROR] [1528993777.347891216]: Could not find the planner configuration 'SPARSkConfigDefault' on the param server
[ERROR] [1528993777.352570257]: Could not find the planner configuration 'SPARStwokConfigDefault' on the param server

i know they are from the drop down menu of the OMPL planning library section. what should i edit to fix this?

EDIT: Current ompl_planning.yaml (fixed through the fix i mentioned)

planner_configs:
  SBL:
    type: geometric::SBL
    range: 0.0  # Max motion added to tree. ==> maxDistance_ default: 0.0, if 0.0, set on setup()
  EST:
    type: geometric::EST
    range: 0.0  # Max motion added to tree. ==> maxDistance_ default: 0.0, if 0.0 setup()
    goal_bias: 0.05  # When close to goal select goal, with this probability. default: 0.05
  LBKPIECE:
    type: geometric::LBKPIECE
    range: 0.0  # Max motion added to tree. ==> maxDistance_ default: 0.0, if 0.0, set on setup()
    border_fraction: 0.9  # Fraction of time focused on boarder default: 0.9
    min_valid_path_fraction: 0.5  # Accept partially valid moves above fraction. default: 0.5
  BKPIECE:
    type: geometric::BKPIECE
    range: 0.0  # Max motion added to tree. ==> maxDistance_ default: 0.0, if 0.0, set on setup ...
(more)
edit retag flag offensive close merge delete

Comments

Have you found a solution to this problem? I am currently going through the same problem. Thanks!

Sanddog23 gravatar imageSanddog23 ( 2018-06-18 21:15:45 -0500 )edit

I believe this is because of a recent update to moveit. Because now the motion planning window is different than it was before

Sanddog23 gravatar imageSanddog23 ( 2018-06-18 21:45:32 -0500 )edit

Afaik the motion planning window (you mean the rviz plugin?) doesn't set these. The launch file(s) do(es).

gvdhoorn gravatar imagegvdhoorn ( 2018-06-19 01:58:40 -0500 )edit

gvdhoorn, the moveit setup assistant creates a .yaml file when you create a moveit config package. it ends up concatenating kconfigdefault to the end of the planner names and confused the system because now RRTConnect is RRTConnectkConfigDefault

nquattro gravatar imagenquattro ( 2018-06-19 09:02:43 -0500 )edit

RRTConnectkConfigDefault is a valid planner configuration name. I don't recognise that as an issue per se.

If you feel this is a regression, then I recommend reporting this over at ros-planning/moveit/issues.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-19 09:17:28 -0500 )edit

@nquattro: can you please include an example ompl_planning.yaml that shows the problem?

Please add it to your original question (edit it).

gvdhoorn gravatar imagegvdhoorn ( 2018-06-19 09:25:33 -0500 )edit

@nquattro: the kConfigDefault should actually be there, for all entries. The changes you suggest in your answer are essentially a 'reverse fix' (ie: you remove something, while it should probably be added). Compare with existing ompl_planning.yaml files.

Please open an issue about this.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-19 10:29:09 -0500 )edit

Is there a reason why it could still be planning even with these errors showing up?

Sanddog23 gravatar imageSanddog23 ( 2018-06-19 12:57:17 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2018-06-19 08:57:02 -0500

nquattro gravatar image

The only solution i have found, and be careful when you adjust these, is to comment the section that concatenates the planner name with the kConfigDefault out entirely. i haven't ran into any issues from doing this, but if it screws up anything else let me know: the CPP file you have to edit is moveit_config_data.cpp, and you need to be running moveit from the git repo or else you don't have this file search for these lines:

// Output associated planners
emitter << YAML::Key << "default_planner_config" << YAML::Value
        << group_meta_data_[group_it->name_].default_planner_ + "kConfigDefault";
emitter << YAML::Key << "planner_configs";
emitter << YAML::Value << YAML::BeginSeq;
for (std::size_t i = 0; i < pconfigs.size(); ++i)
  emitter << pconfigs[i] + "kConfigDefault"
emitter << YAML::EndSeq;

mainly just search for kconfigdefault, and you'll find the section. change it to

// Output associated planners
emitter << YAML::Key << "default_planner_config" << YAML::Value
        << group_meta_data_[group_it->name_].default_planner_;// + "kConfigDefault";
emitter << YAML::Key << "planner_configs";
emitter << YAML::Value << YAML::BeginSeq;
for (std::size_t i = 0; i < pconfigs.size(); ++i)
  emitter << pconfigs[i];//+ "kConfigDefault"
emitter << YAML::EndSeq;

all i did was literally comment out the section that concatenated the text to the planner names. once you comment that out, catkin make, then launch setup assistant, recreate all of the moveit files, and it should be fine. yaml files are just data packets, so if you rename the packet that its looking for, like the above code did, it cannot find it and it gets confused. but once you comment it out, everything in the yaml file that is generated now coincides, and the planner names at the top of the ompl_planning.yaml now match the planning configs at the bottom, where the array of names for the planners are arranged. i believe that this is probably some small Boolean issue, but at this point this seems to work, generate a moveit config folder that works and i haven't had any issues yet.

but do post is this helped you and worked, Sanddog23, im curious.

edit flag offensive delete link more

Comments

It would probably be best if I gave some context on what I am doing. I am trying to plan pre-defined paths of a 6 joint dynamixel arm using the RViz Motion Planning tool. Before updating to the newest version of the moveit library this Motion Planning tool looked different than it does now.

Sanddog23 gravatar imageSanddog23 ( 2018-06-19 12:29:59 -0500 )edit

Even though I am still getting those errors I can still plan movements to my arm through this motion planning tool. It also seems to be smoother when moving to different paths. I am debating on whether to revert back to the previous release of moveit before these updates took place.

Sanddog23 gravatar imageSanddog23 ( 2018-06-19 12:32:44 -0500 )edit

Some control code that I wrote for my arm to needs to be changed because now the library is different for MoveGroupCommander which now takes a 'ns' parameter when initializing where it hadn't before.

Sanddog23 gravatar imageSanddog23 ( 2018-06-19 12:35:12 -0500 )edit

I did not attempt to try this fix because I am still getting planning abilities...

Sanddog23 gravatar imageSanddog23 ( 2018-06-19 12:58:08 -0500 )edit

Really: please report this as an issue on the moveit issue tracker.

@Sanddog23 and @nquattro: is there some reason you're not willing to do this?

gvdhoorn gravatar imagegvdhoorn ( 2018-06-20 02:05:41 -0500 )edit

@gvdhoorn, Terribly sorry, I have been busy, and it has not created an error for me since. I will post a link to my issue on: https://github.com/ros-planning/movei...

sorry about the lateness, and I appreciate the help you have given me.

nquattro gravatar imagenquattro ( 2018-06-21 10:38:03 -0500 )edit

No need to be terribly sorry about it. I was just surprised by the apparent unwillingness to report this as an issue. But it's done and that's ok.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-21 12:01:00 -0500 )edit

Hello. Has the issue been solved? Or the 'reverse fix' is the only solution? I have the same problem as the one described in the original question. Thank you in advance.

akosodry gravatar imageakosodry ( 2018-07-12 08:19:43 -0500 )edit
0

answered 2018-08-29 19:44:11 -0500

mlautman gravatar image

updated 2018-08-30 11:28:24 -0500

This should be fixed by https://github.com/ros-planning/moveit/pull/1040 which was just merged.

If you build the newest version of MoveIt! from source and run roslaunch <robot>_moveit_config setup_assistant.launch -> edit your planning groups -> select a default planner to regenerate ompl_planning.yaml it should fix the issue

edit flag offensive delete link more
0

answered 2018-08-23 08:29:48 -0500

I still encountered this problem in Aug 2018 both in kinetic and lunar. So according to nquattro' answer, it's a parsing problem. Here is a quick solution instead of changing the source codes of MoveIt. In ompl_planning.yaml, the first part seems to be the configurations and the second part seems to be the planning names. Deleting all the "kconfigdefault" string after each planning name will fix this problem.

For example, change "SBLkconfigdefault" to "SBL". Don't forget to change the planning algorithm name in your codes if you use codes instead of the rviz tool.

edit flag offensive delete link more

Comments

I also encountered the problem in kinetic. Yongming's suggestion above solved the problem, thank you! I do hope this solution has no side effects.

jeroemdm gravatar imagejeroemdm ( 2018-09-27 04:21:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-06-14 11:49:21 -0500

Seen: 1,781 times

Last updated: Aug 30 '18