Ask Your Question
0

Unable to load a custom controller

asked 2018-06-13 15:58:19 -0600

venkisagunner gravatar image

I created a custom controller for my omni wheel drive and listed it in my yaml file. But when I tried to launch, Im getting the following error. Tried searching the forum but unable to find an answer that works.

[ERROR] [1528923166.098299551]: Could not load class omni_drive/OmniDrive: Failed to load library /home/user/catkin_ws/devel/lib//libomni_drive.so. Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = /home/user/catkin_ws/devel/lib//libomni_drive.so: undefined symbol: _ZN10omni_drive9OmniDrive8startingERKN3ros4TimeE)
[ERROR] [1528923166.098353074]: Could not load controller 'omni_drive' because controller type 'omni_drive/OmniDrive' does not exist.
[ERROR] [1528923166.098364745]: Use 'rosservice call controller_manager/list_controller_types' to get the available types
[ERROR] [1528923167.100094]: Failed to load omni_drive
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-13 16:58:02 -0600

venkisagunner gravatar image

forgot to add the class reference in the front of start and stop methods. Use c++filt -n _ZN10omni_drive9OmniDrive8startingERKN3ros4TimeE. That solved the problem for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-13 15:58:19 -0600

Seen: 103 times

Last updated: Jun 13 '18