MoveIt! Joystick Control FPS Drops to 0

asked 2018-06-13 14:41:38 -0600

roskbot gravatar image

Hi all!

I'm having a bit of a strange issue with MoveIt! when trying to integrate joystick control. My overall goal is to be able to use MoveIt with an xbox controller as well as a kinect to avoid obstacles in an octomap. However, when I try to implement joystick control the fps of MoveIt in Rviz drops to 0. I assume the issue is not graphical because running just Rviz and MoveIt with an octomap does not cause significant fps drop, but when I launch the joystick_control package I immediately see the fps drop to 0.

The isolated commands I'm running are: -roslaunch <robot_name>_moveit_config demo.launch -roslaunch <robot_name>_moveit_config joystick_control.launch

I'm allowing external command in Rviz and don't know what might be causing this massive framerate drop. My joystick_control.launch file is entirely unaltered and I'm wondering if perhaps something in my demo.launch file is causing MoveIt to wait for a certain process or something along those lines. The only addition I've made to my demo.launch file is the inclusion of the octomap code:

<rosparam command="load" file="$(find &lt;robot_name&gt;_moveit_config)/config/sensors_kinect.yaml"/>

I also don't think it is a controller problem because running jstest /dev/input/js0 results in very clear controller operation. Any help would be appreciated on this.

edit retag flag offensive close merge delete

Comments

I've got the same problem. Have you found a solution?

Andrew Dassonville gravatar image Andrew Dassonville  ( 2020-02-22 02:17:16 -0600 )edit