Ask Your Question
0

Error installing ROS on RPI 3B+

asked 2018-06-11 05:15:48 -0600

xtrix gravatar image

updated 2018-06-11 05:19:12 -0600

I am trying to folow this guide to install ROS on a Raspberry Pi 3 B+ with Debian-Stretch and at 4.1 point I need to folow this guide where I managed to reach the 3.2 Rebuild your workspace point. This is the point where I get this error:

==> Processing catkin package: 'pluginlib'
==> Building with env: '/home/pi/ros_catkin_ws/devel_isolated/rosconsole/env.sh'
==> cmake /home/pi/ros_catkin_ws/src/pluginlib -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/pluginlib -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -G Unix Makefiles in '/home/pi/ros_catkin_ws/build_isolated/pluginlib'
-- Using CATKIN_DEVEL_PREFIX: /home/pi/ros_catkin_ws/devel_isolated/pluginlib
-- Using CMAKE_PREFIX_PATH: /home/pi/ros_catkin_ws/devel_isolated/rosconsole;/opt/ros/kinetic
-- This workspace overlays: /home/pi/ros_catkin_ws/devel_isolated/rosconsole;/opt/ros/kinetic
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/pi/ros_catkin_ws/build_isolated/pluginlib/test_results
-- Found gmock sources under '/usr/src/googletest': gmock will be built
-- Found gtest sources under '/usr/src/googletest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.7.11
CMake Warning at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package):
  Could not find a package configuration file provided by "class_loader" with
  any of the following names:

    class_loaderConfig.cmake
    class_loader-config.cmake

  Add the installation prefix of "class_loader" to CMAKE_PREFIX_PATH or set
  "class_loader_DIR" to a directory containing one of the above files.  If
  "class_loader" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:4 (find_package)


-- Could not find the required component 'class_loader'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "class_loader" with
  any of the following names:

    class_loaderConfig.cmake
    class_loader-config.cmake

  Add the installation prefix of "class_loader" to CMAKE_PREFIX_PATH or set
  "class_loader_DIR" to a directory containing one of the above files.  If
  "class_loader" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:4 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/pi/ros_catkin_ws/build_isolated/pluginlib/CMakeFiles/CMakeOutput.log".
See also "/home/pi/ros_catkin_ws/build_isolated/pluginlib/CMakeFiles/CMakeError.log".
<== Failed to process package 'pluginlib': 
  Command '['/home/pi/ros_catkin_ws/devel_isolated/rosconsole/env.sh', 'cmake', '/home/pi/ros_catkin_ws/src/pluginlib', '-DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/pluginlib', '-DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /home/pi/ros_catkin_ws/build_isolated/pluginlib && /home/pi/ros_catkin_ws/devel_isolated/rosconsole/env.sh cmake /home/pi/ros_catkin_ws/src/pluginlib -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/pluginlib -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -G 'Unix Makefiles'

Command failed, exiting.

Before this error I got another 2-3 errors that I managed to resolve but this is beyond my power.

edit retag flag offensive close merge delete

Comments

Running sudo ./src/catkin/bin/catkin_make_isolated --install-space /opt/ros/kinetic I manage toinstall 57 package from 121 needed.

xtrix gravatar image xtrix  ( 2018-06-11 05:22:43 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-06-12 04:11:07 -0600

suoxd123 gravatar image

"Could not find a package configuration file"

Maybe check it.

edit flag offensive delete link more
0

answered 2018-06-12 03:02:38 -0600

Humpelstilzchen gravatar image

The obvious error is that you are missing a file named "class_loaderConfig.cmake" or "class_loader-config.cmake". According to packages.debian.org you can find the missing file in the package libclass-loader-dev.

Note that you will probably need to install many more of these dependencies.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-11 05:15:48 -0600

Seen: 1,012 times

Last updated: Jun 12 '18