Ask Your Question
0

ROS cannot find a node [closed]

asked 2018-06-06 17:10:48 -0500

Raisintoe gravatar image

I have successfully installed teb_local_planner on my machine using 'sudo apt-get install ros-kinetic-teb-local-planner'. This package includes the test_optim_node node, and I can look up the node under /opt/ros/kinetic/lib/teb_local_planner.

The trouble comes when I try running the node, 'rosrun teb_local_planner test_optim_node'. ROS knows where the package, 'teb_local_planner' is, but cannot locate the node 'test_optim_node'. There must be a simple way to fix this problem, but I do not know how.

I have also tried cloning teb_local_planner from GitHub, but I cannot build the package from the source, because of an error that I have trouble resolving.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Raisintoe
close date 2018-06-06 17:21:19.205332

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-06 17:20:58 -0500

Raisintoe gravatar image

I found the solution after a bit more searching in the ROS forums:

https://answers.ros.org/question/2641...

Because I had tried building from source first, I still needed to delete files in my workspace.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-06-06 17:10:48 -0500

Seen: 56 times

Last updated: Jun 06 '18