Workspace correct build?

asked 2018-06-01 05:33:06 -0500

roboticRaspi gravatar image

Hello I am new to ROS. I have read and tried various tutorials on wiki.ros.org . My current try is to install a ROS with the ur_modern_drivers on my Raspberry Pi 3B. First i tried to install it on a RPi 3b+, but due to the problem, that a suitable OS cannot be installed yet on the RPI 3B+ i downgraded to the RPi 3B. I tried it with Raspbian Jessie and Stretch, and it worked almost perfect, but the ur drives made several different problems. Then i tried it with Ubuntu Mate Xenial 16.04 as suggested in the wiki. But now I stuck again with the ur_modern_drivers. When i want to install it with catkin_make, i get following error:

The specified base path "path/ur_modern_driver" contains a package but "catkin_make" must be invoked in the root of workspace

I googeled the problem and yeah i can read the problem. I tried to build it in

user@pi:/opt/ros/kinetic/etc/catkin - folder woth only profile.d

user@pi:/catkin_ws/ - i created the workspace and cloned the repository

user@pi:/opt/ros/kinetic/etc/catkin_ws - i created the workspace and cloned the repository

I was not able to locate catkin_ws, and in my catkin folder there is no devel nor build nor src. I am aware of that: Wiki Answers and followed that possible fix.

Now to my question: Is my workspace built correctly? If not, how can i do that? Or do you know how i can fix "catkin_make" must be invoked in the root of workspace problem? And yeah i tried to (re)install the whole system, and nothing changed.

Thanks in advance

edit retag flag offensive close merge delete

Comments

Just a note: the fact that you're trying to build ur_modern_driver has no influence on your current problem at all.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-01 05:59:53 -0500 )edit