Ask Your Question
0

Error: The manifest (with format version 2) must not contain the following tags: run_depend

asked 2018-05-31 17:37:08 -0500

rahvee gravatar image

On ROS indigo, I followed the actionlib instructions to create a simple actionclient and actionserver. I was careful to click "indigo" so I'm not accidentally following the instructions for the wrong distribution. When I run catkin_make, I get an error message:

Error(s) in package '/home/eharvey/catkin_ws/src/poi_scan/package.xml':
Error(s):
- The manifest (with format version 2) must not contain the following tags: run_depend

Am I doing something wrong? Or is there an error in the docs?

Here are the complete steps to reproduce:

cd ~catkin_ws/src
catkin_create_pkg poi_scan std_msgs rospy roscpp
cd poi_scan
vi package.xml
mkdir action
vi action/DoDishes.action
vi CMakeLists.txt
mkdir scripts
vi scripts/simple_action_client.py
vi scripts/simple_action_server.py
chmod +x scripts/*
cd ~/catkin_ws
catkin_make

Here are the contents of package.xml:

<?xml version="1.0"?>
<package format="2">
  <name>poi_scan</name>
  <version>0.0.0</version>
  <description>The poi_scan package</description>
  <maintainer email="edward.harvey@todo.todo">turtlebot</maintainer>
  <license>GPLv3</license>
  <buildtool_depend>catkin</buildtool_depend>
  <build_depend>roscpp</build_depend>
  <build_depend>rospy</build_depend>
  <build_depend>std_msgs</build_depend>
  <build_depend>actionlib</build_depend>
  <build_depend>actionlib_msgs</build_depend>
  <build_export_depend>roscpp</build_export_depend>
  <build_export_depend>rospy</build_export_depend>
  <build_export_depend>std_msgs</build_export_depend>
  <exec_depend>roscpp</exec_depend>
  <exec_depend>rospy</exec_depend>
  <exec_depend>std_msgs</exec_depend>
  <run_depend>actionlib</run_depend>
  <run_depend>actionlib_msgs</run_depend>
  <export>
  </export>
</package>

I can share the contents of the other files too, if needed, but catkin_make seems to be choking on package.xml

I found this discussion on stackoverflow, where the accepted answer is to omit the format. Unfortunately, when I omit the format, the problem gets worse:

Error(s) in package '/home/eharvey/catkin_ws/src/poi_scan/package.xml':
Error(s):
- The manifest (with format version 1) must not contain the following tags: build_export_depend, exec_depend
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2018-05-31 18:09:10 -0500

marguedas gravatar image

updated 2018-05-31 18:12:28 -0500

The issue is that the actionlib tutorial has not been updated since catkin_create_pkg has been updated (and now generates package.xml format 2).

Can you try to replace the 2 run_depend with exec_depend ?

Edit: tutorial has been updated: http://wiki.ros.org/action/info/actio...

edit flag offensive delete link more

Comments

Thank you! :-D

rahvee gravatar imagerahvee ( 2018-06-01 06:35:52 -0500 )edit

As an FYI, I ran into this problem when working through the custom global planner plugin tutorial, so that page may need to be updated as well?

M@t gravatar imageM@t ( 2019-06-06 20:56:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-05-31 17:37:08 -0500

Seen: 1,962 times

Last updated: May 31 '18