Ask Your Question
0

How to configure a roslaunch xml to run a node that specifies a path?

asked 2018-05-30 18:15:02 -0600

lyph gravatar image

updated 2018-05-30 18:28:48 -0600

I'm trying to run

rosrun ORB_SLAM2 RGBD PATH_TO_VOCABULARY PATH_TO_SETTINGS_FILE

within a .launch file and I don't know how to specify the path

I tried something like the following but it didn't run.

<node pkg= "ORB_SLAM2" type= "RGBD" args= "<path1> <path2>">

My example:

<launch>
    <include file="/home/mesa/catkin_ws/src/mavros/mavros/launch/px4.launch"/>
    <include file="/opt/ros/kinetic/share/freenect_launch/launch/freenect.launch"/> 
    <node pkg= "ORB_SLAM2" type= "RGBD" args= "/home/mesa/cavedrone/ORB_SLAM2/Vocabulary/ORBvoc.txt /home/mesa/cavedrone/ORB_SLAM2/tcp_rgbd/bin/kinect.yaml" >

</launch>

The error I get

Invalid roslaunch XML syntax: mismatched tag: line 6, column 2
edit retag flag offensive close merge delete

Comments

Something like that should work. Please edit your question to include the exact launch file and the error message that you get when you try to run it.

ahendrix gravatar imageahendrix ( 2018-05-30 18:22:07 -0600 )edit

Okay, updated

lyph gravatar imagelyph ( 2018-05-30 18:28:49 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-05-30 19:01:13 -0600

jayess gravatar image

updated 2018-05-30 19:01:39 -0600

The error tells you the problem

Invalid roslaunch XML syntax: mismatched tag: line 6, column 2

Take a look at your node tag, it's missing the / at the end. Change it to

<node pkg= "ORB_SLAM2" type= "RGBD" args= "/home/mesa/cavedrone/ORB_SLAM2/Vocabulary/ORBvoc.txt /home/mesa/cavedrone/ORB_SLAM2/tcp_rgbd/bin/kinect.yaml" />

Note how I added the / at the end of the node tag.

edit flag offensive delete link more

Comments

Thank you! Also as a note for others I needed to add a name so I had something like name = "foo" into the line for the launch file to run.

lyph gravatar imagelyph ( 2018-05-30 19:16:02 -0600 )edit

Np. Please click on the checkmark to mark the answer as correct.

jayess gravatar imagejayess ( 2018-05-30 19:21:44 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-30 18:14:35 -0600

Seen: 196 times

Last updated: May 30 '18