Unable to connect to yumi robot

asked 2018-05-30 04:47:34 -0600

ccopot gravatar image

I am using Ubuntu 16.04 with ROS Kinetic and I am trying to connect to the Yumi robot (for this I use the https://github.com/OrebroUniversity/yumi and the catkin_make was successful), but I have the following error:

Failed to connect to server, rc: -1. Error: 'Connection refused' (errno: 111)
Failed to receive message length
Failed to receive incoming message

while in the FlexPendant I have:

ROS_StateServer->StateServer: Waiting for connection.
ROS_MotionServer->MotionServer: Waiting for connection
ROS_StateServer-> client connected 
ROS_MotionServer -> client connected

This is confusing me; am I or not connected to the robot? I tried with both network connection, the service port and the regular one, but I get the same error.

If I do rostopic echo joint_states I received some data but is not correct (the position of joints is [0 0 0 0 0 0 0], while should have other configuration)

I have followed the tutorials RobotStudio, InstallServer and RunServer and I do not know what am I doing wrong. Can you help me with some sugestions?

Thanks in advanced!

edit retag flag offensive close merge delete

Comments

I'm not sure you can follow the regular abb_driver installation and setup tutorials for the package you are using. At the very least I would expect that you'd need two instances of the ROS_StateServer and ROS_MotionServer tasks on the controller.

gvdhoorn gravatar imagegvdhoorn ( 2018-05-30 05:37:56 -0600 )edit

I would suggest you take a look at kth-ros-pkg/yumi, which is a continuation of the pkg that you linked to. It also has documentation specifically for setting things up with that pkg (as the abb_driver tutorials do not apply here).

gvdhoorn gravatar imagegvdhoorn ( 2018-05-30 05:39:00 -0600 )edit

Also, for the future: you only link to OrebroUniversity/yumi, but then mention names of tutorials on the ROS wiki pages of the ros-industrial/abb_driver package. Please always link to all on-line resources you are using / referring to, as otherwise we cannot help you.

gvdhoorn gravatar imagegvdhoorn ( 2018-05-30 05:40:13 -0600 )edit

Thank you for your fast reply and for suggestions! I will have a look at kth-ros-pkg/yumi and hope I can solve my issue. Also for future I will add the link to all on-line resources I used.

ccopot gravatar imageccopot ( 2018-05-31 00:57:30 -0600 )edit