Why does the global planner ignore the robots footprint?

asked 2018-05-24 11:18:41 -0600

Hakaishin gravatar image

updated 2018-05-24 11:19:36 -0600

I have a base footprint set but the global planner completely ignores it and makes plans really close to objects. The local planner then corrects this and takes the base footprint into account. But it still leads to very sub optimal travel. Is there an option to enable the global path planner to take a robots footprint into account or is this not possible?

edit retag flag offensive close merge delete

Comments

have you ever configured the footprint in global_costmap

pengjiawei gravatar imagepengjiawei ( 2018-05-24 21:01:47 -0600 )edit

Yes I did configure my robot radius to be 0.45. But you clearly see that the global path goes right next to some objects like the inflation radius is 0.15 with a scaling factor of 10 and the global plan makes a plan that goes right trough 15cm away from the object, even though it should be at 45cm.

Hakaishin gravatar imageHakaishin ( 2018-05-25 07:46:53 -0600 )edit

Did you add the inflation layer ?

pengjiawei gravatar imagepengjiawei ( 2018-05-25 20:00:12 -0600 )edit