How to use bloom-generate with private dependencies [closed]

asked 2018-05-23 10:13:57 -0600

harrisonmg gravatar image

I am trying to create a .deb using

bloom-generate rosdebian --os-name ubuntu --os-version xenial --ros-distro kinetic [package]

on two packages in my ROS Kinetic catkin workspace. The first package, A, only depends on public ROS packages, like message_generation and message_runtime. This generates a debian just fine. The second package, B, depends on A, and when I try to generate a .deb, it returns the error Could not resolve rosdep key 'A'.

A similar problem was presented in this question, however it was resolved that a bloom update added the ability to generate releases that depended on other packages in the repository. My version of python-bloom is 0.6.4-1, though that feature seems to have been added by version 0.2.13. I wonder if there is some option I can't find to enable this feature.

I have created a simple Catkin workspace to reproduce this issue, where package "b" depends on package "a". Clone the repo, catkin_make it, and source devel/setup.bash. Then, substituting for OS differences, run

bloom-generate rosdebian --os-name ubuntu --os-version xenial --ros-distro kinetic src/a

in the root of the workspace. This should work fine. Then, run

bloom-generate rosdebian --os-name ubuntu --os-version xenial --ros-distro kinetic src/b

to observe the key resolution error.

Thanks for your help! Please let me know if there is anymore information I can provide to be helpful.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by nuclearsandwich
close date 2018-05-23 10:16:59.344036

Comments

1

This looks like a duplicate of https://answers.ros.org/question/2802...

If you need clarification on any point please either revise your question or add a comment to the one linked above and I'll update that answer.

nuclearsandwich gravatar imagenuclearsandwich ( 2018-05-23 10:18:09 -0600 )edit
harrisonmg gravatar imageharrisonmg ( 2018-05-23 16:47:28 -0600 )edit