Ask Your Question
0

when I try to compile tf tutorials file listener.cpp it shows the error as mentioned??

asked 2018-05-21 12:04:34 -0600

dark_poison gravatar image

updated 2018-05-21 14:08:53 -0600

gvdhoorn gravatar image

plain dump of the error message:

make[2]: *** No rule to make target 'learning_tf/CMakeFiles/turtle_tf_listener.dir/build'.  Stop.
CMakeFiles/Makefile2:6741: recipe for target 'learning_tf/CMakeFiles/turtle_tf_listener.dir/all' failed
make[1]: *** [learning_tf/CMakeFiles/turtle_tf_listener.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[  0%] Built target tf_generate_messages_cpp
[  0%] Built target actionlib_generate_messages_eus
[  0%] Built target turtle_tf_broadcaster
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
edit retag flag offensive close merge delete

Comments

2

Can you show us the contents of your CMakeLists.txt file, then we might be able to help you.

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2018-05-21 13:50:19 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-21 13:31:36 -0600

simbha gravatar image

You have to change the CMakeLists.txt. Add the executable and target to CMakeLists.txt.

Follow this link: Building your nodes

edit flag offensive delete link more

Comments

I already did that still same error

dark_poison gravatar image dark_poison  ( 2018-05-21 13:37:27 -0600 )edit

You might have done mistake in doing that. Please check again otherwise share your package link

simbha gravatar image simbha  ( 2018-05-21 13:40:25 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-05-21 12:04:34 -0600

Seen: 419 times

Last updated: May 21 '18