Ask Your Question
1

compile RViz or ros_gui: python-qt-bindings missing

asked 2012-03-05 02:51:52 -0500

felix k gravatar image

I am trying to compile ros_gui or rviz on Xubuntu 11.10 within current electric, but without any success.

I did the usual clone for rviz, and a roslocate info with rosinstall for ros_gui. Everywhere the package or rosdep python-qt-bindings is referenced, but apart from this kforge project it's kind of inexistent. And it does not work. What have I done wrong?

Maybe this output helps:

$ rosdep satisfy rviz
Failed to find rosdep libqt4-dev for package rviz on OS:ubuntu version:oneiric
Failed to find rosdep qt4-qmake for package rviz on OS:ubuntu version:oneiric
Failed to find rosdep libqt4-opengl-dev for package rviz on OS:ubuntu version:oneiric
Failed to find rosdep python-qt-bindings for package rviz on OS:ubuntu version:oneiric
error in processing scripts ABORTING: Rosdeps [u'libqt4-dev', u'qt4-qmake', u'libqt4-opengl-dev', u'python-qt-bindings'] could not be resolved
Failed to find rosdep libqt4-dev for package rviz on OS:ubuntu version:oneiric
Failed to find rosdep qt4-qmake for package rviz on OS:ubuntu version:oneiric
Failed to find rosdep libqt4-opengl-dev for package rviz on OS:ubuntu version:oneiric
Failed to find rosdep python-qt-bindings for package rviz on OS:ubuntu version:oneiric
The following rosdeps are not installed but are required [u'libqt4-dev', u'qt4-qmake', u'libqt4-opengl-dev', u'python-qt-bindings']
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-03-08 04:14:58 -0500

hersh gravatar image

The Fuerte versions of RViz and ros_gui both depend on the new little stack called python_qt_binding. There only exists a Fuerte version of python_qt_binding, it did not exist in Electric.

So if you are trying to build the latest rviz and ros_gui code (Fuerte versions) under Electric, it just won't work.

However, Fuerte is coming along pretty well these days, we are close to releasing it. If you do

sudo apt-get install ros-fuerte-visualization

you should get the latest Fuerte version of rviz, already compiled and everything.

Fuerte has a number of important differences from Electric. See http://ros.org/wiki/fuerte. As ever, you will need to source /opt/ros/fuerte/setup.bash after installing and before doing

rosrun rviz rviz

If you have other software which is not ready to build or run in Fuerte, you can still run rviz in a Fuerte-ized shell and run your Electric software in an Electric-ized shell. Since ROS communication is serialized between processes, as long as the message definitions are the same on both sides, it works fine. Most ROS messages that I've dealt with lately have not changed between Electric and Fuerte, so I think it is a pretty viable way to proceed.

It is true that we still have more work to do documenting the python_qt_binding package, sorry that is confusing.

edit flag offensive delete link more

Comments

Oh, hadn't thought of that. But, I was trying electrics rviz, which did not work. Oh! I chose the trunk URL from the wiki, tags/electric is building fine. The same with the rviz from /opt/. But now I can test the new rviz. :)

felix k gravatar image felix k  ( 2012-03-08 05:07:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-03-05 02:51:52 -0500

Seen: 712 times

Last updated: Mar 08 '12