Ask Your Question
0

'select timeout' when running 'usb_cam_node' [closed]

asked 2018-05-14 03:59:37 -0500

tengfei han gravatar image

updated 2018-05-14 18:55:13 -0500

I planned to rerun the ORB_SLAM2 open codes using TUM database on my PC. I have finished all installation of dependdencies and downloaded all codes we need to used in this process,

then

cd ~/orbslam_ws
source devel/setup.bash
roslaunch usb_cam usb_cam-test.launch

error message:

[ERROR] [1526278532.672410250]: select timeout
[camera-1] process has died [pid 103266, exit code 1, cmd /home/htf/orbslam_ws/devel/lib/usb_cam/usb_cam_node /usb_cam/image_raw:=/camera/image_raw __name:=camera __log:=/home/htf/.ros/log/78bb35ae-573d-11e8-a5a9-000c291bb522/camera-1.log].
log file: /home/htf/.ros/log/78bb35ae-573d-11e8-a5a9-000c291bb522/camera-1*.log

these disgusting errors were displayed on the terminal. I am just a naive beginner of SLAM and ROS, Does anyone could help me to solve this problem ? thank you very much.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by tengfei han
close date 2018-07-13 01:16:02.743077

Comments

3

these disgusting errors

do you mean "unexpected"?

gvdhoorn gravatar image gvdhoorn  ( 2018-05-14 05:38:30 -0500 )edit

It looks like your launching a node which is trying to connect to an actual hardware camera, is this your intention?

PeteBlackerThe3rd gravatar image PeteBlackerThe3rd  ( 2018-05-14 12:45:17 -0500 )edit

yes,you are right . I planned to test my monocular camera

tengfei han gravatar image tengfei han  ( 2018-05-14 18:50:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-15 07:13:02 -0500

Hi There, you question states you are trying to test ORB_SLAM2 with the TUM data set and then your say you're trying to test your monocular camera. These are mutually exclusive you cannot be doing both.

Your error message is caused because the usb_cam node is failing to start so I'd investigate this on its own first. You seem to have built it from source as well which is probably not necessary.

So I'd recommend trying to get the usb_cam_node working properly first, calibrate your camera as described here, then try and integrate this with the ORB_SLAM2 system.

edit flag offensive delete link more

Comments

thank you for your reply. I have fixed this problem. but there is another question after calibrated the camera. https://answers.ros.org/question/2911... Do you know why?

tengfei han gravatar image tengfei han  ( 2018-05-15 19:12:06 -0500 )edit

Question Tools

Stats

Asked: 2018-05-14 03:59:37 -0500

Seen: 2,517 times

Last updated: May 15 '18