Ask Your Question
0

Razor_imu_9dof can't see my Sparkfun IMU (14001)?

asked 2018-05-09 12:32:05 -0500

roach374 gravatar image

updated 2018-05-10 05:50:41 -0500

gvdhoorn gravatar image

I'm running kinetic on Ubuntu 16.04 (x86).

I've followed the instructions for razor_imu_9dof, for the Razor SEN-14001 M0 board from Sparkfun. I flashed the AHRS firmware, and installed all the relevant ROS packages. I am able to see the IMU spewing data on /dev/ttyACM0, by running cat or screen.

However, when I run

roslaunch razor_imu_9dof razor-pub-and-display.launch

I just get the error:

[ERROR] [1525842655.072800]: IMU not found at port /dev/ttyACM0. Did you specify the correct port in the launch file?

What am I doing wrong? Is there a way to troubleshoot?

edit retag flag offensive close merge delete

Comments

Just to check you're not trying to run the launch file at the same time as viewing the output using cat or screen are you?

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-05-09 15:26:52 -0500 )edit

No, I did that separately, add part of my naive attempt to troubleshoot. One thing I did notice though, the /dev/ttyACM0 device is owned by root/dialout. Maybe it's a permissions issue? I tried running sudo roslaunch, but it barfed with "unrecognized command".

roach374 gravatar imageroach374 ( 2018-05-09 15:55:28 -0500 )edit

if cat can read from the port then it should be fine. You can always use chmod to set the permissions of /dev/ttyACM0 . Note they will be reset every time to plug it in.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-05-09 16:06:52 -0500 )edit

We've got a few of these in our lab, I can check what the output should look like tomorrow so you can check the firmware is correct.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-05-09 16:11:44 -0500 )edit

I think I've figured it out. It WAS a permissions issue. I added my user account to the dialout group, and things seem to be working fine now. Thanks!

roach374 gravatar imageroach374 ( 2018-05-09 23:09:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-09 23:09:52 -0500

roach374 gravatar image

Turned out to be a permissions issue. I added my user account to the dialout group, and everything started working.

edit flag offensive delete link more

Comments

This is the answer, but I can't accept it, since I don't have enough karma.

roach374 gravatar imageroach374 ( 2018-05-09 23:10:27 -0500 )edit

Glad you got this working

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-05-10 06:25:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-09 12:03:45 -0500

Seen: 376 times

Last updated: May 10 '18