Ask Your Question
0

Couldn't find executable named rqt_graph

asked 2018-04-28 01:51:57 -0600

frodyteen gravatar image

updated 2018-06-27 19:11:30 -0600

jayess gravatar image

I'm running on ubuntu 14.04 indigo. since I don't have Internet access from the computer that I am working on, therefore I cannot use sudo apt-get ... commands. Therefore, I used a usb to transfer all the files. I used this link to make sure I am downloading the right for my system.

I built rqt(0.4.8) and rqt_graph(0.4.8) from the source, when I ran catkin_make, it builts successfully. However, when I try to ran rosrun rqt_graph rqt_graph

it shows me the following:

/catkin_ws$ rosrun rqt_graph rqt_graph

[rosrun] Couldn't find executable named rqt_graph below /home/administrator/catkin_ws/src/rqt_graph

[rosrun] Found the following, but they're either not files,

[rosrun] or not executable:

[rosrun] /home/administrator/catkin_ws/src/rqt_graph

[rosrun] /home/administrator/catkin_ws/src/rqt_graph/src/rqt_graph

[rosrun] /home/administrator/catkin_ws/src/rqt_graph/scripts/rqt_graph

So I went into rqt_graph/script/rqt_graph and made it into an executable, then I ran rosrun rqt_graph rqt_graph again, and it gave me the following:

RosPluginProvider.load(rqt_graph/RosGraph) exception raised in __builtin__.__import__(rqt_graph.ros_graph, [RosGraph]): Traceback (most recent call last):

File "/home/administrator/catkin_ws/src/rqt_gui/src/rqt_gui/ros_plugin_provider.py", line 77, in load module = __builtin__.__import__(attributes['module_name'], fromlist=[attributes['class_from_class_type']], level=0) File "/home/administrator/catkin_ws/src/rqt_graph/src/rqt_graph/ros_graph.py", line 38, in <module> from python_qt_binding.QtWidgets import QCompleter, QFileDialog, QGraphicsScene, QWidget

ImportError: No module named QtWidgets

PluginManager._load_plugin() could not load plugin "rqt_graph/RosGraph": Traceback (most recent call last):

File "/home/administrator/catkin_ws/src/qt_gui/src/qt_gui/plugin_handler.py", line 99, in load self._load()

File "/home/administrator/catkin_ws/src/qt_gui/src/qt_gui/plugin_handler_direct.py", line 54, in _load self._plugin = self._plugin_provider.load(self._instance_id.plugin_id, self._context)

File "/home/administrator/catkin_ws/src/qt_gui/src/qt_gui/composite_plugin_provider.py", line 71, in load instance = plugin_provider.load(plugin_id, plugin_context)

File "/home/administrator/catkin_ws/src/qt_gui/src/qt_gui/composite_plugin_provider.py", line 71, in load instance = plugin_provider.load(plugin_id, plugin_context)

File "/home/administrator/catkin_ws/src/rqt_gui_py/src/rqt_gui_py/ros_py_plugin_provider.py", line 60, in load return super(RosPyPluginProvider, self).load(plugin_id, plugin_context)

File "/home/administrator/catkin_ws/src/qt_gui/src/qt_gui/composite_plugin_provider.py", line 71, in load instance = plugin_provider.load(plugin_id, plugin_context)

File "/home/administrator/catkin_ws/src/rqt_gui/src/rqt_gui/ros_plugin_provider.py", line 83, in load raise e

ImportError: No module named QtWidgets

Anyone got suggestions on how I should fix this?

edit retag flag offensive close merge delete

Comments

Looks like something is missing. Try running:

rosdep check rqt_graph
alex_ gravatar imagealex_ ( 2018-04-28 02:07:49 -0600 )edit

shows me: apt ros-indigo-qt-dotgraph, so I downloaded the 0.2.32 version. Now, when I do run rosrun rqt_ tab tab, it actually shows me rqt_graph, but it still gave me the error saying can't find an executable. Then, when I made it an executable, it shows me the import error.

frodyteen gravatar imagefrodyteen ( 2018-04-28 02:28:29 -0600 )edit

What version of the package ros-indigo-python-qt-binding do you have installed?

Dirk Thomas gravatar imageDirk Thomas ( 2018-04-30 11:52:44 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-06-28 17:36:43 -0600

frodyteen gravatar image

I ended up configuration multiple computer network, so that I can connect to the Husky PC1 with PC2 that has wifi. Once, the rqt_graph is downloaded on PC2, I configured the network to connect PC2 to PC1, then, from PC2, I can use rqt_graph to see all the nodes and topics.

edit flag offensive delete link more
0

answered 2018-04-28 08:28:40 -0600

You can still install the package using apt-get even if you're not connected to the internet:

apt-get download <package name>

You can download the debian packages as files, transfer them over on a USB stick and then install them from these files using apt-get.

sudo dpkg -i <downloaded_package.deb>

You may have to do this a few times installing dependencies, but hopefully this method will hopefully make your life a lot easier

edit flag offensive delete link more

Comments

Thanks for the reply, can you point me where to download debian packages for iindigo rqt_graph ?

frodyteen gravatar imagefrodyteen ( 2018-04-28 12:28:45 -0600 )edit

I believe @PeteBlackerThe3rd already did that. Just use:

apt-get download ros-indigo-rqt-graph

that should download things for you.

gvdhoorn gravatar imagegvdhoorn ( 2018-04-28 12:40:01 -0600 )edit

okay, can you also provide information on where to download the debian packages, so I can use sudo dpkg -i <downloaded_package.deb> Thank you.

frodyteen gravatar imagefrodyteen ( 2018-04-28 12:55:59 -0600 )edit

? That is exactly what apt-get download does. Have you tried it?

gvdhoorn gravatar imagegvdhoorn ( 2018-04-28 12:58:35 -0600 )edit

just ran it right now, and it shoed me the following:

WARNING: the following packages cannot be authenticated!

ros-indigo-rqt-graph
frodyteen gravatar imagefrodyteen ( 2018-04-28 13:56:22 -0600 )edit

That would seem to point to a configuration issue on your system. Make sure you've imported the key for the OSRF repositories.

gvdhoorn gravatar imagegvdhoorn ( 2018-04-28 14:11:25 -0600 )edit

Okay, would the following be the way to import the key?

sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116

I did the above, and it gave me a timeout:

gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
frodyteen gravatar imagefrodyteen ( 2018-04-28 20:12:17 -0600 )edit

And you're attempting to import the key on the PC with internet, correct?

Are you behind a firewall / corporate proxy by any chance?

In any case: @PeteBlackerThe3rd's suggestion is sound: apt-get download will get you all the debs.

You'll need to fix the system configuration issue.

gvdhoorn gravatar imagegvdhoorn ( 2018-04-29 01:08:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-04-28 01:51:57 -0600

Seen: 451 times

Last updated: Jun 28 '18