Ask Your Question
0

(Hector Slam)catkin_make error on raspberry pi3, very slow compiling

asked 2018-04-24 00:49:03 -0600

DongHyeong Kang gravatar image

updated 2018-04-24 00:52:57 -0600

Hi there , I trying to install hector slam package on raspberry pi3 (ubuntu mate)

I installed hector slam package through git clone command

But the error generated when I compiled it. (scanning dependencies of target)

the phenomenon is that compiling speed was very slow (almost stop)

How can i solve this problem?? I have to implement hector mapping on raspberry pi3. please answers..

Someone told me to install through apt-get (It does not require compilation <- right?)

I'm sorry my grammer T.T

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-03 22:08:49 -0600

DrBot gravatar image

Ubuntu Mate has a lot of overhead. Try the Raspberry Pi distribution from downloads.ubiquityrobotics.com . If you have trouble compiling with a default catkin_make, use the -j1 parameter, it takes longer but may work if the default -j4 fails.

edit flag offensive delete link more

Comments

HOw can I change -j4 to -j1?

v.leto gravatar imagev.leto ( 2019-11-02 09:58:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-04-24 00:49:03 -0600

Seen: 195 times

Last updated: Jul 03 '18