ROS2 Talker Listener not communicating

asked 2018-04-20 19:40:22 -0500

linzoi gravatar image

Hi, I have recently upgraded to ros ardent and have been struggling recently with getting ros2 nodes to communicate on my laptop (despite it previously working with r2b2).

Here is what I have tried to no avail :

Sourcing all combination of setup.bash, setup.sh, local_setup.sh etc..

Building ROS ardent from source and sourcing appropriate files in install directory.

Sourcing my previous r2b2 installation (which worked fine some time in the past fine) and trying the demo nodes. Still does not work.

Changing RMW implementation form fast_rtps to openslice and connext.

Starting and stopping the ros daemon manually to look for any meaningful output.

Publishing chatter message manually from one terminal and trying to listen in the other terminal. I.e

ros2 topic pub /chatter std_msgs/String "data: Hello world"

NB: every time I run the talker, when I run "ros2 node list" or "ros2 topic list" in another terminal nothing comes up.

I have two questions :

a. Is there any log file output or debug output that I can look at to determine why things are not working ?

Thanks,

Lindsay

edit retag flag offensive close merge delete

Comments

Since you're building from source, you can get some debug logging output from the "internals" of ROS 2 by adding this line to the talker:

rcutils_logging_set_logger_level("", RCUTILS_LOG_SEVERITY_DEBUG);

Investigating with wireshark can help too.

dhood gravatar imagedhood ( 2018-05-02 16:21:06 -0500 )edit