Ask Your Question
0

Creating COLLADA (.dae) files for visual tag in Gazebo/ROS

asked 2018-04-10 05:37:28 -0500

znbrito gravatar image

updated 2018-04-10 07:03:08 -0500

Hi,

I am on Ubuntu 16.04 LTS and ROS Kinetic right now and trying to import a model that I designed in SolidWorks (a simple tree made with sticks, its in a .sldprt file) into my Gazebo simulation. I know that URDF files only support .stl and collada (.dae) files and that I should use .stl files for the collision tag and .dae for the visual tag. I can properly export my model using the SolidWorks2URDF plugin ( http://wiki.ros.org/sw_urdf_exporter ) and I get a package with an URDF file which includes an .stl file for both visual and collision tags, because the exporter doesn't export any collada (.dae) files.

I tried to use the SimLab Soft Collada Exporter for SolidWorks to export my model into to a collada file but when I tried to use it in the simulation, the only thing that appears is a white cube (???) and I don't know why because if I open the file in FreeCad, I can see my tree with no problems, except the fact that it is colourless and I don't know why... first my model had a wood appearence but then I changed it to a brown color, just to check that the appearance had nothing to do with this, but I still see the white cube as my visual object while my collision object (orange) stays correct:

image description

I have also tried to convert my model file from .sldprt to .stp file (format 214 so that it also has colors but not appearances) and follow the steps in here http://gazebosim.org/tutorials?tut=gu... to convert my file into a collada one but everything remains the same.

Can somebody help me on how to do this? Thanks in advance!

Best regards, José Brito

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-04-10 07:13:45 -0500

znbrito gravatar image

Hi,

solved the problem. When a white cube appears on Gazebo that means that the path to the visual mesh in not well specified. I guess I wasn't expecting this error because I was using the package finder, but when I used the full path the tree appear and everything seemed to be fine. After that I changed to the package finder once again and I got no errors so it seems that the first time I inserted the path I must have misspelled something...

Anyway, just in case you guys want to know, when you are working with SolidWorks to build your own models:

  • The SolidWorks2URDF (link: http://wiki.ros.org/sw_urdf_exporter ) plugin works just fine but doesn't export COLLADA models, which means you have to get them through another plugin, which is the SimLab Collada Exporter.

  • The SimLab Collada Exporter ( https://www.simlab-soft.com/3d-plugin... ) is supported on SolidWorks 2013 and more recent versions. It is a payed software but you can use a free trial license for 30 days that works just fine. Keep in mind that this plugin can't export any appearances to a COLLADA file, only normal colors, i.e., the RBG combinations.

(I also discovered that it is not possible to export appearances to a STEP (.stp file), which was something that I also tried when trying to work my problem around).

Combining this 2 SolidWorks plugins allowed me to fully export a SolidWorks model, which is something that I think that is not well documented on the Internet so I hope this helps you all as it helped me.

Cheers! José Brito

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-04-10 05:37:28 -0500

Seen: 432 times

Last updated: Apr 10 '18