/cmd_VEL topic is missing

asked 2018-04-09 15:39:17 -0500

Caesar84 gravatar image

updated 2018-04-10 13:19:51 -0500

jayess gravatar image

hi ,

i have installed (again) Indigo with its default Gazebo as well as Hector_quadrotor link text. I cant find the topic /cmd_vel in order to send a flying command. also , i did install ardrone_autonomy plus tum_simulator and the same situation . here is a list of the topics when launching

roslaunch cvg_sim_gazebo ardrone_testworld.launch

according to iolyp/tum-simulator-indigo:

$ rostopic list

/aerodynamics/wrench
/altimeter
/altimeter/parameter_descriptions
/altimeter/parameter_updates
/clock
/command/motor
/command/wrench
/fix
/fix/position/parameter_descriptions
/fix/position/parameter_updates
/fix/status/parameter_descriptions
/fix/status/parameter_updates
/fix/velocity/parameter_descriptions
/fix/velocity/parameter_updates
/fix_velocity
/gazebo/link_states
/gazebo/model_states
/gazebo/parameter_descriptions
/gazebo/parameter_updates
/gazebo/set_link_state
/gazebo/set_model_state
/ground_truth/state
/joint_states
/magnetic
/magnetic/parameter_descriptions
/magnetic/parameter_updates
/motor_pwm
/motor_status
/pressure_height
/propulsion/wrench
/quadro/trigger
/raw_imu
/raw_imu/accel/parameter_descriptions
/raw_imu/accel/parameter_updates
/raw_imu/bias
/raw_imu/rate/parameter_descriptions
/raw_imu/rate/parameter_updates
/raw_imu/yaw/parameter_descriptions
/raw_imu/yaw/parameter_updates
/rosout
/rosout_agg
/sonar_height
/sonar_height/parameter_descriptions
/sonar_height/parameter_updates
/supply
/tf
/tf_static
/wind

had anyone seen such a thing before ? ps: i think in both cases i saw the same topics (hector and ardrone).

thanks in advance


Update

I am facing the same situation with Kinetic on Ubuntu 16.04 and gazebo 7 , there is no /cmd_vel topic

edit retag flag offensive close merge delete

Comments

Can you confirm that you tried calling the service rosservice call /enable_motors "enable: true"?

stevejp gravatar imagestevejp ( 2018-04-10 15:53:54 -0500 )edit

yes i did and restarted the whole thing couple of times.

Caesar84 gravatar imageCaesar84 ( 2018-04-10 18:25:51 -0500 )edit

I had the same problem when I tried to simu multi-uav with hector. Some of the uavs' "cmd_vel" were missing while the others were well. But, I didn.t meet it when I tried one uav.

nm46nm gravatar imagenm46nm ( 2018-04-11 21:42:58 -0500 )edit