Ask Your Question
0

Unable to launch turtlebot3 waffle

asked 2018-04-08 19:50:35 -0600

hstusnick gravatar image

I have a turtlebot3 that was a burger that we are changing to a waffle. I followed the steps here: http://emanual.robotis.com/docs/en/pa... to set up the ide then followed the directions here: http://emanual.robotis.com/docs/en/pl... to upload the waffle code instead of the burger code.

Now, when we call up the tb3 using the command roslaunch turtlebot3_bringup turtlebot3_core.launch the turtlebot starts but fails. Here is part of the terminal output:

Then we have another error: Further in the log after 'Calibration end' we get on repeat until I control-c, I have tried using both the shell and the arduino ide methods for uploading the example code for the waffle and have gotten the same result. I have also now tried to revert it back to the burger using both methods and still receive this issue. I am using the launch files provided robotis on the pi.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-04-08 20:53:26 -0600

Darby Lim gravatar image

Hi :)

I can't see your capture or something you type terminal output And if you want to get an information about it, please visit issue page in github turtlebot3 repo

edit flag offensive delete link more

Comments

Sorry these are pictures the pi had trouble opening a browser so I just took a picture instead. https://imgur.com/BueKGLA and https://imgur.com/oHBBlI8

hstusnick gravatar imagehstusnick ( 2018-04-08 21:37:36 -0600 )edit

@hstusnick please don't use an image to display text. Images are not searchable and people cannot copy and paste the text from the image. Please update your question with a copy and paste of the text.

jayess gravatar imagejayess ( 2018-04-09 02:34:08 -0600 )edit
1

Hi :) I checked your error messages. Next time copy and paste of the text would be help

Because of mismatch message types between turtlebot3_core.ino and turtlebot3_bringup, you have faced that problem. Please check firmware version(the latest is v1.1.2) and download turtlebot3 code in github repo

Darby Lim gravatar imageDarby Lim ( 2018-04-09 19:39:21 -0600 )edit

Thank you! It ended up that I was using 1.1.2 on my opencr board but the pi I was using with it was outdated so updating the turtlebot3 bringup files worked.

hstusnick gravatar imagehstusnick ( 2018-04-12 10:57:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-08 19:50:35 -0600

Seen: 115 times

Last updated: Apr 08 '18