Ask Your Question
0

ros-indigo package not found

asked 2018-04-06 02:01:33 -0500

codeahead gravatar image

I have been following for installing ROS-Indigo on my Ubuntu 14.04.1 (installed in VirtualBox on Windows 10).

After the sudo apt-get update command, I tried running the sudo apt-get install ros-indigo-desktop-full command, however the following error popped up:

E: Unable to locate package ros-indigo-desktop-full.

Further I tried running the following commands as well, but to no avail:

  1. sudo apt-get install ros-indigo-desktop
  2. sudo apt-get install ros-indigo-ros-base

They gave the same package not found error.

I searched the Ubuntu 14.04 package list here, and did not seem to find any package related to ros-indigo.

Note: I am not much experienced with the Linux environment and would be grateful for any help in this regard.

Thank You

edit retag flag offensive close merge delete

Comments

You might have missed a step in the installation tutorials. What is the output of:

ls -al /etc/apt/sources.list.d

If there is no file that adds the ROS repositories there, that might be your problem.

Alternatively, something could have gone wrong while importing the key. I'd check that too.

gvdhoorn gravatar image gvdhoorn  ( 2018-04-06 02:32:38 -0500 )edit

The output of ls -al /etc/apt/sources.list.d is empty, i.e. there is nothing inside the sources.list.d directory.

I followed this tutorial, and here it creates opt dir inside /etc and there I can see this file ros-latest-list. Does this mean anything?

codeahead gravatar image codeahead  ( 2018-04-06 10:10:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-04-06 11:01:02 -0500

gvdhoorn gravatar image

I would recommend to follow the regular installation tutorial: wiki/indigo/Installation/Ubuntu.

In any case: there is a typo in the tutorial you link: it should be apt, not opt (note: a, not o).

edit flag offensive delete link more

Comments

Thank You for pointing out the typo. The installation works now.

codeahead gravatar image codeahead  ( 2018-04-08 06:17:39 -0500 )edit

You should probably report that typo to the author(s) of the tutorial you were following.

Without the fix, nothing will ever work.

gvdhoorn gravatar image gvdhoorn  ( 2018-04-08 11:15:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-04-06 02:01:33 -0500

Seen: 1,677 times

Last updated: Apr 06 '18