Ask Your Question

RGBDSLAMv2 REQUIRED process [rgbdslam-1] has died!

asked 2018-04-04 08:01:37 -0500

Dox gravatar image

updated 2018-04-13 16:56:16 -0500

Hi I am using Ubuntu 16.04 LTS on athlon i686 with ROS Kinetic and Kinect XBOX 360. I've installed rgbdslamv2 using script from the official github repo. I've tried launching every launch file in /launch directory, but I always get the following error message:

======REQUIRED process [rgbdslam-1] has died!
process has died [pid 5855, exit code -11, cmd /home/doxub/rgbdslam_catkin_ws/devel/lib/rgbdslam/rgbdslam __name:=rgbdslam __log:=/home/doxub/.ros/log/61c2e24e-3806-11e8-8d8c-101f744a42d4/rgbdslam-1.log].
log file: /home/doxub/.ros/log/61c2e24e-3806-11e8-8d8c-101f744a42d4/rgbdslam-1*.log
Initiating shutdown!
[rgbdslam-1] killing on exit
shutting down processing monitor...

I've seen that others also had similar issues, reported here and here. I tried following this instructions on how to compile Rgbdslam (V2) on a Fresh Ubuntu 16.04 Install (Ros Kinetic) but without success. If someone is able to provide me with any insight on how to solve this problem it would be much appreciated. Thanks!

edit retag flag offensive close merge delete


Found this and at step 19. when I try to source ~/catkin_ws/install/setup.bash I get the message "No such file or directory". Can anyone help, pls?

Dox gravatar image Dox  ( 2018-04-06 16:41:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-09-20 08:51:02 -0500

I think you should try the setup.bash in the document called "devel" .Or you go first check whether the setup.bash is in the "install" by $ cd ~/catkin_ws/install/ and $ ls .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-04-04 08:01:37 -0500

Seen: 1,254 times

Last updated: Apr 13 '18