Ask Your Question
0

ROS - Turtlebot simulator problem: the turtlebot model does not appear on Gazebo.

asked 2018-03-27 11:11:05 -0600

Cholopineco gravatar image

updated 2018-03-28 04:50:19 -0600

hi, i'm a beginner with ROS world.

I use Ubuntu 16.04 (on virtual machine), Kinetic, gazebo 7.

When i execute roslaunch turtlebot_gazebo turtlebot_world.launch, Gazebo starts and models of the 3D world appear, but there is no turtlebot model!

The terminal give me this error:

IOError: [Errno 13] Permission denied: '/home/user/.ros/rosdep/sources.cache/index'
[spawn_turtlebot_model-3] process has died [pid 4179, exit code 1, cmd /opt/ros/kinetic/lib/gazebo_ros/spawn_model -unpause -urdf -param robot_description -model mobile_base __name:=spawn_turtlebot_model __log:=/home/user/.ros/log/62c9e862-31d6-11e8-b9a2-080027f2d824/spawn_turtlebot_model-3.log].
log file: /home/user/.ros/log/62c9e862-31d6-11e8-b9a2-080027f2d824/spawn_turtlebot_model-3*.log

I do not understand anything. How to solve?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-03-28 04:52:05 -0600

gvdhoorn gravatar image
IOError: [Errno 13] Permission denied: '/home/user/.ros/rosdep/sources.cache/index'

you've ran sudo rosdep update at some point in the past.

You shouldn't do that (and you should also have been given a warning about that by rosdep).

Try the following and see whether things improve:

sudo rosdep fix-permissions
edit flag offensive delete link more

Comments

it works! Thanks so much for helping!

Cholopineco gravatar imageCholopineco ( 2018-03-28 08:31:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-27 11:11:05 -0600

Seen: 403 times

Last updated: Mar 28 '18