ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

unable to install moveit on kinetic

asked 2018-03-24 04:52:20 -0500

Prof. xavier gravatar image

updated 2018-03-24 05:22:10 -0500

gvdhoorn gravatar image

Hey, I am a beginner, I am trying to install moveit on kinetic and I am facing problems. I am using virtual box for linux and everything worked fine but when tried to install moveit, I faced a lot of problems.

when I tried : sudo apt-get install ros-kinetic-moveit I got following issue

Err:1 xenial/main amd64 libfcl0.5 amd64 0.5.0-3osrf1~xenial3
  Temporary failure resolving ''
Err:2 xenial/main amd64 libfcl-0.5-dev amd64 0.5.0-3osrf1~xenial3
  Temporary failure resolving ''
Err:3 xenial/main amd64 ros-kinetic-controller-manager-msgs amd64 0.13.0-0xenial-20180222-201631-0800
  Temporary failure resolving ''
Err:4 xenial/main amd64 ros-kinetic-object-recognition-msgs amd64 0.4.1-0xenial-20180222-205043-0800
  Temporary failure resolving ''
Err:5 xenial/main amd64 ros-kinetic-octomap-msgs amd64 0.3.3-0xenial-20180222-204232-0800
  Temporary failure resolving ''
Err:6 xenial/main amd64 ros-kinetic-moveit-msgs amd64 0.9.1-0xenial-20180222-205707-0800
  Temporary failure resolving ''
Err:7 xenial/main amd64 ros-kinetic-urdfdom-py amd64 0.3.3-0xenial-20180222-191425-0800
  Temporary failure resolving ''
Err:8 xenial/main amd64 ros-kinetic-srdfdom amd64 0.4.2-1xenial-20180222-231036-0800
  Temporary failure resolving ''
Err:9 xenial/universe amd64 libccd2 amd64 2.0-1
  Temporary failure resolving ''
Err:10 xenial/main amd64 ros-kinetic-moveit-core amd64 0.9.11-0xenial-20180223-010000-0800
  Temporary failure resolving ''
Err:11 xenial/universe amd64 libccd-dev amd64 2.0-1
  Temporary failure resolving ''
Err:12 xenial/main amd64 ros-kinetic-moveit-ros-perception amd64 0.9.11-0xenial-20180309-123628-0800
  Temporary failure resolving ''
Err:13 xenial/main amd64 libglew-dev amd64 1.13.0-2
  Temporary failure resolving ''
Ign:14 xenial/main i386 python-bs4 all 4.4.1-1
Err:15 xenial/main amd64 ros-kinetic-moveit-ros-planning amd64 0.9.11-0xenial-20180309-131351-0800
  Temporary failure resolving ''
Ign:16 xenial/main i386 python-html5lib all 0.999-4
Err:17 xenial/main amd64 ros-kinetic-warehouse-ros amd64 0.9.0-0xenial-20180223-005508-0800
  Temporary failure resolving ''
Err:18 xenial/main amd64 python-lxml amd64 3.5.0-1build1
  Temporary failure resolving ''
Err:19 xenial/main amd64 ros-kinetic-moveit-ros-warehouse amd64 0.9.11-0xenial-20180309-133506-0800
  Temporary failure resolving ''
Ign:20 xenial/universe i386 python-pyassimp all 3.2~dfsg-3
Err:21 xenial/main amd64 ros-kinetic-moveit-kinematics amd64 0.9.11-0xenial-20180309-133451-0800
  Temporary failure resolving ''
Err:14 xenial/main i386 ...
edit retag flag offensive close merge delete


This is your 4th question that I have to correct the formatting of.

Please use the Preformatted Text button (the one with 101010 on it) to properly format console text.

Paste the text, select it all, press the button or use ctrl+k.

Without proper formatting, it's really hard to read.

gvdhoorn gravatar image gvdhoorn  ( 2018-03-24 05:24:35 -0500 )edit

sorry sir, I did not realise it. I will take care of it.

Prof. xavier gravatar image Prof. xavier  ( 2018-03-26 17:26:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-03-24 05:21:53 -0500

gvdhoorn gravatar image

updated 2018-03-24 05:26:50 -0500

Temporary failure resolving ''

This is not a Moveit specific problem: your computer virtual machine is unable to translate the domain name into its IP address and because of that can't download the packages it needs.

Does ping work?


I am using virtual box for linux

Please make sure you have a correctly working network setup for your virtual machine. If that is not working it could cause the problem you are having.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-03-24 04:52:20 -0500

Seen: 1,101 times

Last updated: Mar 24 '18