Ask Your Question
2

get rid of warning: Inbound TCP/IP connection failed

asked 2018-03-23 03:27:37 -0600

knxa gravatar image

updated 2018-04-02 02:26:14 -0600

I get this warning intermittently:

Inbound TCP/IP connection failed: connection from sender terminated before handshake header received. 0 bytes were received. Please check sender for additional details.

I see this sometimes when a subscriber unsubscribes a topic. I am assuming the warning is issued if the unsubscription happens while the next message is already coming in. The concrete place I am seeing this is when using smach monitor_state. When a monitored topic delivers a message that satisfies the state, it unsubscribes, and sometimes, I see the above warning.

I want to get rid of warnings, when they really don't indicate a problem.

Can I unsubscribe in a way that is more "clean" and doesn't cause this warning?

edit retag flag offensive close merge delete

Comments

Did you find the source of this warning showing up>

azerila gravatar image azerila  ( 2020-05-30 14:51:24 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-06-08 05:58:10 -0600

skyap gravatar image

maybe you have solve it. remove rospy.spin() after your callback and change to

while not rospy.is_shutdown():
    continue
edit flag offensive delete link more

Comments

is there a reason for which this helps? I also have the same warning sometimes showing up in my ros application although it doesn't seem to effect the behaviour of it. But I don't know what the source of it can be. however, I have a node that I keep alive with a while loop but not using rospy.is_shutdown().

azerila gravatar image azerila  ( 2020-05-30 14:50:50 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2018-03-23 03:27:37 -0600

Seen: 2,389 times

Last updated: Apr 02 '18