Ask Your Question
0

How to disable timeout in diagnostics aggregator?

asked 2018-03-21 10:48:53 -0500

Cerin gravatar image

To cut down on CPU and message traffic, I modified the dignostics publishing in my system to only report ERROR messages, and not OK messages. However, now the diagnostics viewer is showing several topics as "stale", even though I've set timeout to -1 as mentioned in the docs.

My analyzers.yaml looks like:

pub_rate: 1.0
base_path: ''
analyzers:
  sensors:
    type: AnalyzerGroup
    path: Sensors
    analyzers:
      imu_calibration:
        type: GenericAnalyzer
        path: IMU Calibration
        timeout: -1
        contains:
        -   imu_calib

and the diagnostics viewer is showing an item called "Sensors->IMU Calibration = STALE". Why is this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-02 06:12:58 -0500

knxa gravatar image

I assume this is related to the bug reported here. The bug has apparently been fixed but is not yet in the officially released packages.

I found a very similar issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-21 10:48:53 -0500

Seen: 41 times

Last updated: Apr 02