ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Running ROS in a Tensorflow virtual environment

asked 2018-03-14 22:48:38 -0500

RohitM gravatar image

I run Tensorflow in a virtual environment and I want to run a python node in this virtual environment. I'm getting an error saying:

ImportError: No module named 'rospkg'

I've tried running source ./devel/setup.bash but that didn't help solve the problem.

Does anyone have any suggestions on how to solve this problem?

Thanks in advance.

edit retag flag offensive close merge delete



Hi pleas see this question

Hamid Didari gravatar image Hamid Didari  ( 2018-03-18 00:45:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-03-18 00:50:01 -0500

RohitM gravatar image

Thanks for the reply. Turns out that I needed to pip install rospkg catkin_pkg

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-03-14 22:48:38 -0500

Seen: 1,842 times

Last updated: Mar 14 '18