Ask Your Question
0

Astra Pro RGB & Depth publishing rate not quite same. [Closed]

asked 2018-03-13 01:21:31 -0500

PKumars gravatar image

updated 2018-03-13 05:00:09 -0500

Hello all, I want to use Orbbec Astra Pro in ROS Indigo inside Ubuntu 14.04. I have installed the ROS compatible OPenNI2 and now able to run the launch code. The Astra Pro Camera starts perfectly without any issue.

Now the problem is when i check the publishing rate of RGB and Depth stream I see that they are not quite same.

Here are the outputs..

image description

image description

What can I do to get 30hz publish rate for both RGB and Depth

Cheers,

Prasanna

edit retag flag offensive close merge delete

Comments

Please check our support guidelines, specifically the Do Not section, which states:

DO NOT post a screenshot of the terminal or source file.

gvdhoorn gravatar imagegvdhoorn ( 2018-03-13 03:23:34 -0500 )edit

OK Sir, it was a mistake. It won't be repeated. But I'm closing this issue as I have found the bug.

PKumars gravatar imagePKumars ( 2018-03-13 04:55:29 -0500 )edit

Just keep it in mind for your next question.

But I'm closing this issue as I have found the bug.

It would be nice if you could post what you found as an answer and then accept your own answer.

gvdhoorn gravatar imagegvdhoorn ( 2018-03-13 04:56:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-13 04:58:09 -0500

PKumars gravatar image

updated 2018-03-13 05:02:47 -0500

Sorry for the silly question. I solved the issue.

Here is a solution to my problem regarding the publish rate of RGB image.

previously it was . and thats way I was getting 15Hz rate, but now it's 30Hz as I have changed it.

before --------- param name="frame_rate" value="15"

after --------- param name="frame_rate" value="30"

This is for the libuvc_ros driver that I'm using for Astra Pro with astra_pro.launch file.

using the following command

$ roslaunch astra_launch astra_pro.launch

<node pkg="libuvc_camera" type="camera_node" name="astra_pro_uvc">
    <!-- Parameters used to find the camera -->
    <param name="vendor" value="0x2bc5"/>
    <param name="product" value="0x0501"/>
    <param name="serial" value=""/>
    <!-- If the above parameters aren't unique, choose the first match: -->
    <param name="index" value="0"/>

    <!-- Image size and type -->
    <param name="width" value="640"/>
    <param name="height" value="480"/>
    <!-- choose whichever uncompressed format the camera supports: -->
    <param name="video_mode" value="uncompressed"/> <!-- or yuyv/nv12/jpeg -->
    <param name="frame_rate" value="30"/>
    <param name="frame_id" value="$(arg camera)_rgb_optical_frame"/>

    <param name="timestamp_method" value="start"/> <!-- start of frame -->


    <!-- Change has to be done here to add the camera calibration file-->

    <!-- <param name="camera_info_url" value="file:///tmp/cam.yaml"/> -->




    <param name="auto_exposure" value="3"/> <!-- use aperture_priority auto exposure -->
    <param name="auto_white_balance" value="false"/>
  </node>

</group> <!-- rgb -->

Thanks,

Prasanna

edit flag offensive delete link more

Comments

previously it was .

it was what?

gvdhoorn gravatar imagegvdhoorn ( 2018-03-13 04:59:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-13 01:21:31 -0500

Seen: 395 times

Last updated: Mar 13 '18