ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Enable different ROS log levels

asked 2018-03-05 18:18:13 -0500

bxl gravatar image

updated 2018-03-06 08:14:36 -0500

I read this tutorial about how to set environment variables to change log level and my config file stayed like this:

 log4j.logger.ros=DEBUG
 log4j.logger.ros.hector_path_follower=DEBUG

ROSCONSOLE_CONFIG_FILE variable is properly set, however rosconsole output doesn't show any message.

So I've got two questions:

1- What possible might be wrong?
2- How can I enable ROS_DEBUG output to be viewed on a file/screen, not only through rosconsole

EDIT:

Running roslaunch file outputs:

log4cxx: Could not read configuration file [/home/bruno/rodain].

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-03-07 08:37:17 -0500

mgruhler gravatar image
  1. the error points to a wrong file location. You have to specify the full path to the file, including the file name and file extension. So if your file is not named /home/bruno/rodain, you need to adapt it to the full file name (e.g. /home/bruno/custom_roslog.conf).
  2. By changing the logger level and putting the output="screen" argument in the respective node tags of your launch file. E.g. <node name="my_node" pkg="my_pkg" type="my_node_executable" output="screen"/>
edit flag offensive delete link more

Comments

@mig Your solution resolved my issue. However, ros_console is not displaying any log messages anymore. I've set my config_file to behave like default, not changed though.

bxl gravatar image bxl  ( 2018-03-12 14:09:13 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2018-03-05 18:18:13 -0500

Seen: 2,308 times

Last updated: Mar 07 '18