Connecting hokuyo UTM-30LX to linux with serial conneciton

asked 2018-03-01 06:17:15 -0600

MMH130 gravatar image

Hello guys,

I am trying to connet my Hokuyo UTM-30LX usb lidar to linux. and as am newbie in linux I went through most of the fourms here and now I am stuck.

I installed the urg_node and whenever I try to connect to the LIDAR using the following command:

rosrun urg_node urg_node

I get the following error

[ERROR] [1519905339.382986585]: Error connecting to Hokuyo: Could not open serial Hokuyo:
/dev/ttyACM0 @ 115200
could not open serial device.

I tried to use the udev to give Hokuyo device name as it is mentioned in http://wiki.ros.org/urg_node :

SUBSYSTEMS=="usb", KERNEL=="ttyACM[0-9]*", ACTION=="add", ATTRS{idVendor}=="15d1", ATTRS{idProduct}=="0000", MODE="666", PROGRAM="/opt/ros/hydro/lib/urg_node/getID /dev/%k q", SYMLINK+="sensors/hokuyo_%c", GROUP="dialout"

but I get the following error :

ATTRS{idVendor}==15d1,: command not found

Can anyone helps with this case so I can get the LIDAR to works on linux kinetic correctly? Would appreciate some assist

edit retag flag offensive close merge delete

Comments

You can check with dmesg before and after plugging the sensor which device it gets and then first manually start the driver to check that it works. Afterwards deal with the correct udev rules. - Are you using hydro? Command has hydro in it.

dornhege gravatar imagedornhege ( 2018-03-01 10:12:20 -0600 )edit

@dornhege well it reads at as following when connected : usb 3-1: New USB device found, idVendor=15d1, idProduct=0000 usb 3-1:New USB device strings: Mfr=1, Product=2, SerialNumber=0 Product: URG-Series USB Driver Manufacturer: Hokuyo Data Flex for USB cdc_acm 3-1:1.0: ttyACM0: USB ACM device

MMH130 gravatar imageMMH130 ( 2018-03-01 12:36:25 -0600 )edit

@dornhege I am not sure what is hydro ? sorry im totally new to linux.

thank you for your fast response and I hope i get a solution with you. so do you have any idea what to do next ?

MMH130 gravatar imageMMH130 ( 2018-03-01 12:38:39 -0600 )edit

@dornhege I noticed the hydro and I changed it to kinetic in the code , still have the same issue

MMH130 gravatar imageMMH130 ( 2018-03-01 12:44:10 -0600 )edit