Ask Your Question
0

Move Base Publishing Y velocities

asked 2018-02-28 02:47:25 -0600

updated 2018-02-28 11:25:07 -0600

jayess gravatar image

Hi,

I've run into this strange behavior while trying to get my robot stack to run in gazebo. I've configured a turtlebot URDF with some 3D sensors and launching my pretty-generic ROS navigation stack configs. All of the sudden, move base is publishing only Y and theta velocities, no X.

I figure it must have to do with the URDF configs I changed or TF from the diff drive gazebo plugins, because I have not changed move_base in this development effort.

Any thoughts? I've become stumped here.

Example messages below: (I can never figure out how to get the markdown to work in ros answers :( )

linear: 
  x: 0.0
  y: 0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 0.714091062546


linear: 
  x: 0.0
  y: 0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 0.0


linear: 
  x: 0.0
  y: 0.0
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: 0.401096045971


linear: 
  x: 0.0
  y: 0.000136807560921
  z: 0.0
angular: 
  x: 0.0
  y: 0.0
  z: -0.800002932549
edit retag flag offensive close merge delete

Comments

To get the syntax highlighting working just copy and paste your code/terminal output into your question, highlight it, then click the preformatted text (101010) button.

jayess gravatar imagejayess ( 2018-02-28 11:27:05 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-02-28 03:00:26 -0600

updated 2018-02-28 03:15:33 -0600

Edit: Lies, it still happens. Something TF related?

Figured it out .

For the next weary soul: Turns out, for the diff drive controller, if you set it to base_footprint, it'll do some weird conversion or interpolation (?) and give you both X and Y components of a non-holonomic robot base.

edit flag offensive delete link more

Comments

But that's not it! Also generally speaking, gazebo is not a happy camper with footprint transforms. Base Link made everyone happy which I'm a little confused by but I suspect TF isn't publishing this fast enough and gazebo has some assumptions in how you set it up.

stevemacenski gravatar imagestevemacenski ( 2018-03-01 12:38:08 -0600 )edit
0

answered 2018-03-01 08:38:55 -0600

David Lu gravatar image

The problem is likely not with move_base but with the odometry topic coming from Gazebo. The local planners aren't always smart about what to do with a velocity from odometry that its parameters say should be impossible.

edit flag offensive delete link more

Comments

Right, the problem went away after I did 2 things: I modified all of my map->odom publishers (AMCL, gmapping, etc) to reference base_link instead of my base_footprint I use for my hardware robots, and launching the simulation before other things come up. I suspect things were in a bad state.

stevemacenski gravatar imagestevemacenski ( 2018-03-01 12:36:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-02-28 02:47:25 -0600

Seen: 100 times

Last updated: Mar 01 '18