Ask Your Question

Dependency error while installing TIAGo [closed]

asked 2018-02-27 09:09:51 -0600

hiteshmankani gravatar image

updated 2018-02-27 10:20:24 -0600

jayess gravatar image


I have recently installed ROS indigo on my VM and have had no issues so far. I have then tried to install the TIAGo robot but I seem to get an error when trying to set up dependency with the following command:

rosdep install --from-paths src --ignore-src --rosdistro indigo --skip-keys="opencv2 opencv2-nonfree pal_laser_filters speed_limit sensor_to_cloud"

ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
pal_hardware_gazebo: Cannot locate rosdep definition for [pal_hardware_interfaces]
temperature_sensor_controller: Cannot locate rosdep definition for [pal_hardware_interfaces]
mode_state_controller: Cannot locate rosdep definition for [pal_hardware_interfaces]

Any help would be appreciated as I am quite new to this!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Procópio
close date 2018-07-06 04:46:50.100984

1 Answer

Sort by » oldest newest most voted

answered 2018-02-28 04:37:21 -0600

This means something went wrong when you followed the install steps. The rosinstall command should have cloned the pal_hardware_interface package into your src/ directory, so rosdep shouldn't try to resolve it to a system dependency. If you follow the steps in the wiki page you've linked to exactly, everything should work.

I've verified that the following steps work on a fresh Ubuntu Trusty installation. They are basically the steps from the wiki page, I didn't adapt anything crucial.

sudo sh -c 'echo "deb trusty main" > /etc/apt/sources.list.d/ros-latest.list'
wget -O - | sudo apt-key add -
sudo apt-get update
sudo apt-get install -y python-rosdep python-rosinstall python-catkin-tools git build-essential cmake
sudo rosdep init
rosdep update

sudo add-apt-repository --yes ppa:xqms/opencv-nonfree
sudo apt-get update
sudo apt-get install -y libopencv-nonfree-dev

# install ros-core, otherwise rosinstall complains that /opt/ros/indigo doesn't exist
sudo apt-get install -y ros-indigo-ros-core

mkdir ~/tiago_public_ws
cd ~/tiago_public_ws
rosinstall src /opt/ros/indigo tiago_public.rosinstall

# Use rosdep to install all dependencies
rosdep install --from-paths src --ignore-src -y --rosdistro indigo --skip-keys="opencv2 opencv2-nonfree pal_laser_filters speed_limit sensor_to_cloud"

source /opt/ros/indigo/setup.bash

# Init catkin workspace
catkin init
# Build packages
catkin build -DCMAKE_BUILD_TYPE=Release
source ~/tiago_public_ws/devel/setup.bash

Here is the Vagrantfile I've created to verify that the instructions work.

edit flag offensive delete link more


Thanks a lot for your reply! I will try these steps again and let you know! Hopefully it works :D

hiteshmankani gravatar imagehiteshmankani ( 2018-02-28 04:57:08 -0600 )edit

Hi, I seem to get this error when building the packages: Not sure how else to post it as it doesnt let me fit more characters. Thanks in advance!

hiteshmankani gravatar imagehiteshmankani ( 2018-02-28 06:43:46 -0600 )edit

any help would be appreciated as this is the next error im getting while following the above steps:

hiteshmankani gravatar imagehiteshmankani ( 2018-03-02 05:48:27 -0600 )edit

The commands I've posted above are verified to work on a clean Ubuntu system. Something in your system seems to be really broken, so it's hard to help you. Please reinstall ROS; if that doesn't help, reinstall your system and try again.

Martin Günther gravatar imageMartin Günther ( 2018-03-02 06:45:11 -0600 )edit

I have tested this on a ROS indigo with Ubuntu. Does this have any effect?

hiteshmankani gravatar imagehiteshmankani ( 2018-03-02 06:53:45 -0600 )edit

ROS Indigo on Ubuntu is exactly right, that's also what I tested it under.

Martin Günther gravatar imageMartin Günther ( 2018-03-05 03:16:14 -0600 )edit

Hi, I have tried it in a freshly installed system and still got the same errors...

hiteshmankani gravatar imagehiteshmankani ( 2018-03-06 10:19:15 -0600 )edit

You can install vagrant (sudo apt-get install vagrant), download the Vagrantfile from my answer and run "vagrant up" in the same directory as the Vagrantfile. That should at least give you a virtual machine with everything installed. I can't tell why it's working in the VM and not on your PC.

Martin Günther gravatar imageMartin Günther ( 2018-03-06 10:55:09 -0600 )edit

Question Tools

1 follower


Asked: 2018-02-27 09:09:51 -0600

Seen: 315 times

Last updated: Mar 02 '18