ROS remote: Communication with node failed

asked 2018-02-21 09:09:35 -0600

Fedja gravatar image

updated 2018-02-21 11:02:27 -0600

jayess gravatar image

Hi,

i'm using a real world jackal and my Laptop as remote machine. Laptop runs Ubuntu 14.04, so as the computer on the jackal (ROS_Distro=indigo). I followed the tutorial http://www.clearpathrobotics.com/asse... , i can list all the topics but i can't echo anything.

rosnode info rosout tells me "ERROR: Communication with node[http://192.168.1.11:53898/] failed!

I set the variables like so:

Laptop's bashrc: export $ROS_MASTER_URI=http://<Jackal_IP>:11311 and export $ROS_IP=<Laptop_IP>.

Jackal's bashrc: export $ROS_MASTER_URI=http://<Jackal_IP>:11311 and export $ROS_IP=<Jackal_IP>.

I did list the jackal hostname in etc/hosts file in the laptops file system.

I need to mention that ifconfig @jackals_mashine shows me wlan0-ip: 172.xx.xx.26 AND br0-ip: 192.168.1.11

My Laptop is in the same network as the jackal (wlan0-ip: 172.xx.xx.28)

Nodes-ip are in the br0 network-space (see error msg above), how can i forward them and echo them from remote mashine (laptop)?

edit retag flag offensive close merge delete