Ask Your Question
2

ROS/Gazebo crashes when spawing PR2 robot model

asked 2012-02-22 21:03:39 -0500

ReiniK gravatar image

updated 2014-11-22 17:05:29 -0500

ngrennan gravatar image

Hello all. I am new to ROS and also to this mailing group, so let me introduce myself breifly:

I am a student in Computer Vision and Robotics and currently working on my master's thesis which needs to be carried out in ROS. I am getting really strange errors when running GAZEBO and spawing a PR2. In fact the entire GAZEBO crashes and I do not know how to track this error.

Here is the error message I get:

[ WARN] [1329924386.489855153, 11.500000000]: You've passed in true for auto_start for the C++ action server at [/head_traj_controller/follow_joint_trajectory]. You should always pass in false to avoid race conditions.
[base_laser_self_filter-23] process has finished cleanly.
log file: /home/reinhard/.ros/log/9799641e-5d66-11e1-8c07-485b39b465c6/base_laser_self_filter-23*.log
respawning...
[base_laser_self_filter-23] restarting process
process[base_laser_self_filter-23]: started with pid [17328]
[ WARN] [1329924386.592470362, 11.506000000]: Shutdown request received.
[ WARN] [1329924386.592511749, 11.506000000]: Reason given for shutdown: [new node registered with same name]
[ WARN] [1329924386.756356578, 11.529000000]: no localization information yet (odom_combined -> base_laser_link)
[ WARN] [1329924386.928924445, 11.546000000]: No collision geometry specified for link 'r_forearm_cam_frame'
Traceback (most recent call last):
File "/opt/ros/electric/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner", line 159, in <module>
if __name__ == '__main__': main()
File "/opt/ros/electric/stacks/pr2_mechanism/pr2_controller_manager/scripts/spawner", line 137, in main
resp = load_controller(name)
File "/opt/ros/electric/stacks/ros_comm/clients/rospy/src/rospy/impl/tcpros_service.py", line 430, in __call__
return self.call(*args, **kwds)
File "/opt/ros/electric/stacks/ros_comm/clients/rospy/src/rospy/impl/tcpros_service.py", line 519, in call
raise ServiceException("transport error completing service call: %s"%(str(e)))
rospy.service.ServiceException: transport error completing service call: unable to receive data from sender, check sender's logs for details
[gazebo-1] process has died [pid 11286, exit code -11].
log files: /home/reinhard/.ros/log/9799641e-5d66-11e1-8c07-485b39b465c6/gazebo-1*.log
[tilt_laser_self_filter-21] process has finished cleanly.
log file: /home/reinhard/.ros/log/9799641e-5d66-11e1-8c07-485b39b465c6/tilt_laser_self_filter-21*.log

It seems that if I launch it with gdb it works, but it is extremely weird and definitely not a permanent solution. But I do not know any other way to fix this ..

I hope someone can help me in this. Thank you all in advance!

Best, Reinhard

edit retag flag offensive close merge delete

Comments

are you: 1. roslaunch gazebo_worlds empty_world.launch 2. roslaunch pr2_gazebo pr2.launch and 3. seeing this crash? is the error message from the first roslaunch console? and can you try attaching gdb to gazebo thread after step 1 and see if you can catch this segfault that way? thanks.

hsu gravatar image hsu  ( 2012-02-23 22:21:45 -0500 )edit

Same problem here. "roslaunch pr2_gazebo pr2_empty_world.launch" leads to a crash in gazebo. The mentioned log file does not exist. Running first 1 and then 2 will kill gazebo in 1 as soon as 2 starts up (exit code -11), and then kill default_controllers_spawner (exit code 1).

AHornung gravatar image AHornung  ( 2012-03-14 03:59:04 -0500 )edit

This happened with the latest ROS electric on two different machines with NVidia graphics card, one Core i7 with Ubuntu 11.10 and one Core i5 with Ubuntu 11.04.

AHornung gravatar image AHornung  ( 2012-03-14 04:03:20 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2012-03-22 15:29:17 -0500

hsu gravatar image

please see my post about nvidia driver in this question, check & downgrade if you have 295.* drivers installed and see if that helps.

edit flag offensive delete link more
0

answered 2012-03-15 13:00:16 -0500

saqbay gravatar image

updated 2012-03-15 13:04:17 -0500

So I have had the same problem this morning, and then the funny thing is, trying to run it using gdb seems to be working. As in, running gazebo via gdb makes the pr2 model spawn process work. I'm thinking if it's a race condition on fast machines. The issue happens on my core i7 870 desktop with NVidia graphics, but not on my core i5-M520 Lenovo laptop with ATI (radeon, not fglrx) graphics.

So I know this is not a solution, but at least it gives me a workaround for now. Maybe that might help you too? And, are you both seeing it occur on (relatively) fast machines?

Documentation on running gazebo under gdb is here (I tried with roslaunch): http://ros.org/wiki/pr2_simulator/Tutorials/RunningSimulatorWithGDB/cturtle

I am using electric, though, and the info there works for that version too.

edit flag offensive delete link more

Comments

can you try logging into your session with gnome classic (no effects) or unity 2d and see if you still get the segfault?

hsu gravatar image hsu  ( 2012-03-15 15:05:18 -0500 )edit

I tried it on my KDE desktop with desktop effect disabled, same effect. There are a couple of warning in the form of "You've passed in true for auto_start for the C++ action server at ... You should always pass in false to avoid race conditions." Could this be the problem?

AHornung gravatar image AHornung  ( 2012-03-16 01:15:41 -0500 )edit

I can only speculate about that at this point. A ROS developer would be the right person to answer that. But I see that message on all machines I run ROS on. Graphics hardware? Not sure. Tested to work in a NVidia GTX 460, but its failing on a GTX 240. Identical software on both machines.

saqbay gravatar image saqbay  ( 2012-03-16 14:07:13 -0500 )edit
0

answered 2012-02-27 05:41:03 -0500

ainbro gravatar image

I am trying to put this in the comments but I cannot find that link so here goes: I have the same problem. This seems to be an issue with pr2 talking to gazebo. both 1. and 2. execute without error.

edit flag offensive delete link more

Comments

Did you manage to fix this somehow? It is still not working on my machine.

ReiniK gravatar image ReiniK  ( 2012-02-28 21:49:17 -0500 )edit
0

answered 2012-02-28 00:00:33 -0500

ReiniK gravatar image

Now after switching computer it works, but it is extremely weird that the exact same code from the same repository works on one machine and gives such strange mistakes on a different one.

edit flag offensive delete link more

Comments

I haven't been able to solve it, and it happens on both computers I tried it on.

AHornung gravatar image AHornung  ( 2012-03-14 04:05:42 -0500 )edit
0

answered 2014-06-24 15:44:33 -0500

2ROS0 gravatar image

I have a similar problem. The errors are different though. Maybe some of the answers on that link might help you as well though. Here it is answers.ros.org/question/174830/pr2-doest-launch-in-gazebo-as-in-tutorial-on-ros-fuerte/ :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-02-22 21:03:39 -0500

Seen: 1,391 times

Last updated: Jun 24 '14