Ask Your Question
1

Error when I run the command: rosrun rqt_graph rqt_graph

asked 2018-02-09 20:42:32 -0500

nrb gravatar image

updated 2018-02-09 21:06:27 -0500

I followed the steps given here : Understanding Topics

I get the following error:

Inspiron-5559:~$ sudo apt-get install ros-kinect-rqt
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-kinect-rqt

When I run rqt : image description

When I run the command :

Inspiron-5559:~$ rosrun rqt_graph rqt_graph
Could not import "pyqt" bindings of qt_gui_cpp library - so C++ plugins will not be available:
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui_cpp/cpp_binding_helper.py", line 43, in <module>
    from . import libqt_gui_cpp_sip
ImportError: dynamic module does not define module export function (PyInit_libqt_gui_cpp_sip)

[WARN] [1518230850.310686]: Failed to load Python extension for LZ4 support. LZ4 compression will not be available.
RosPluginProvider.load(rqt_graph/RosGraph) exception raised in __builtin__.__import__(rqt_graph.ros_graph, [RosGraph]):
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rqt_gui/ros_plugin_provider.py", line 80, in load
    module = __builtin__.__import__(attributes['module_name'], fromlist=[attributes['class_from_class_type']], level=0)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 45, in <module>
    from qt_dotgraph.dot_to_qt import DotToQtGenerator
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 36, in <module>
    import pydot
ModuleNotFoundError: No module named 'pydot'

PluginManager._load_plugin() could not load plugin "rqt_graph/RosGraph":
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/plugin_handler.py", line 99, in load
    self._load()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/plugin_handler_direct.py", line 54, in _load
    self._plugin = self._plugin_provider.load(self._instance_id.plugin_id, self._context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/composite_plugin_provider.py", line 71, in load
    instance = plugin_provider.load(plugin_id, plugin_context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/composite_plugin_provider.py", line 71, in load
    instance = plugin_provider.load(plugin_id, plugin_context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rqt_gui_py/ros_py_plugin_provider.py", line 60, in load
    return super(RosPyPluginProvider, self).load(plugin_id, plugin_context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_gui/composite_plugin_provider.py", line 71, in load
    instance = plugin_provider.load(plugin_id, plugin_context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rqt_gui/ros_plugin_provider.py", line 86, in load
    raise e
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rqt_gui/ros_plugin_provider.py", line 80, in load
    module = __builtin__.__import__(attributes['module_name'], fromlist=[attributes['class_from_class_type']], level=0)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rqt_graph/ros_graph.py", line 45, in <module>
    from qt_dotgraph.dot_to_qt import DotToQtGenerator
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/qt_dotgraph/dot_to_qt.py", line 36, in <module>
    import pydot
ModuleNotFoundError: No module named 'pydot'
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-02-09 23:47:17 -0500

130s gravatar image
E: Unable to locate package ros-kinect-rqt

Wrong prefix. I think you mean ros-kinetic.

ModuleNotFoundError: No module named 'pydot'

rqt_graph depends on qt_dotgraph, which depends on python-pydot. So by the official, formal way of installation like the following, it should be installed.

$ sudo apt-get install ros-kinetic-rqt-graph
[sudo] password for n130s: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  python-pydot ros-kinetic-qt-dotgraph
The following NEW packages will be installed:
  python-pydot ros-kinetic-qt-dotgraph ros-kinetic-rqt-graph
0 upgraded, 3 newly installed, 0 to remove and 9 not upgraded.
Need to get 71.9 kB of archives.
After this operation, 361 kB of additional disk space will be used.
Do you want to continue? [Y/n]
edit flag offensive delete link more
-2

answered 2018-02-09 22:14:29 -0500

nrb gravatar image

use " conda install pydot"

edit flag offensive delete link more

Comments

Other than my answer is likely more standard way of resolving dependency, alternative Python interpreters like Anaconda is discouraged in ROS. See the related thread.

130s gravatar image 130s  ( 2018-02-09 23:49:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-09 20:42:32 -0500

Seen: 1,343 times

Last updated: Feb 09 '18