ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

/clock topic not recived on master

asked 2018-02-07 01:12:08 -0500

updated 2018-02-07 01:13:09 -0500

I am building a G-mapping based SLAM robot .

Master - This is my desktop .

  • roscore is running here
  • is the IP address

Robot - The robot is hooked to a RPI3 .

  • I have added this to the .bashrc file , "export ROS_MASTER_URI="
  • IP address of the RPI is ""

I am publishing /clock (which is required for the node publishing /odom) from the RPI on the Robot .

I am not able to receive the /clock on the Master .

Essentially the client is not able to communicate back with the master , how do i fix it .

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-02-07 02:15:02 -0500

gvdhoorn gravatar image

updated 2018-02-07 02:49:49 -0500

Have you set ROS_IP on both hosts?


Should i set the ROS_IP on both Master and Client ?

Unless you have a working DNS setup for both: yes.

Note: if you have DHCP configured, adding the (current) IP addresses to /etc/hosts is not sufficient, as the IPs may change in the future / on reboot. If you have DHCP, make sure to have proper DNS as well (ie: updated by your DHCP server).

And just making sure: have you checked the ROS/NetworkSetup guide?


On the robot instead of export ROS_IP=, it was export ROS_IP=localhost

I would be very much surprised if that works. It could work now, but I guarantee you that you'll get in trouble later.

edit flag offensive delete link more


Should i set the ROS_IP on both Master and Client ?

chris_sunny gravatar image chris_sunny  ( 2018-02-07 02:27:45 -0500 )edit

Thanks , problem solved . On the robot instead of export ROS_IP= , it was export ROS_IP=localhost

chris_sunny gravatar image chris_sunny  ( 2018-02-07 02:45:04 -0500 )edit

Question Tools

1 follower


Asked: 2018-02-07 01:12:08 -0500

Seen: 204 times

Last updated: Feb 07 '18