Ask Your Question
0

cannot launch node of type [closed]

asked 2018-02-06 09:14:23 -0500

DBServ gravatar image

Hello everybody,

I've got trouble when trying to get my workspace-packages to run. I'm doing the following to build the workspace:

source /opt/ros/kinetic/setup.bash
cd catkin_ws
catkin_make
source ./devel/setup.bash

After that I try to launch the nodes, for example lms1xx

roslaunch lms1xx MRS1000.launch

, which is successfull.

Then I try to launch another node, for example the rosbridge node,

roslaunch rosbridge_server rosbridge_tcp.launch

but here I get the following errors:

ERROR: cannot launch node of type [rosbridge_server/rosbridge_tcp]: can't locate node [rosbridge_tcp] in package [rosbridge_server]
ERROR: cannot launch node of type [rosapi/rosapi_node]: can't locate node [rosapi_node] in package [rosapi]

When I try to launch one another node, here the node for pointcloud of zed-camera

roslaunch zed_pointcloud 2dscan.launch

I get a different error-message than befor:

ERROR: cannot launch node of type [pointcloud_to_laserscan/pointcloud_to_laserscan_node]: pointcloud_to_laserscan
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/serva-eve/catkin_ws/src
ROS path [2]=/opt/ros/kinetic/share

I'm a noob working with ROS. So I don't get why there are different error-messages and what they mean. I know that I have to source the .bash-file to get the right path, so I did that like I explained at the top.

Can please somebody help and tell me what the errors mean and what I can do to fix them.

Thank you very much in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by DBServ
close date 2018-02-07 08:58:31.838870

Comments

Are you opening new terminals each time you use a different launch file?

jayess gravatar imagejayess ( 2018-02-06 11:04:27 -0500 )edit

No it should be possible to launch the files in my home-directory, where my workspace lies as well. At least I think so... My goal is to start all nodes in my workspace with one single launch-file. At the moant I only can try to launch the single nodes, because of the given errors...

DBServ gravatar imageDBServ ( 2018-02-07 00:24:34 -0500 )edit

what was your solution to this problem?

aarontan gravatar imageaarontan ( 2018-06-27 09:39:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-06 13:52:54 -0500

NEngelhard gravatar image

updated 2018-02-07 00:51:38 -0500

jayess gravatar image

You haven't installed the packages. For the last error, you could try to install the package via

sudo apt install ros-kinetic-pointcloud-to-laserscan ros-kinetic-rosbridge-server
edit flag offensive delete link more

Comments

Thank you very much for your help. I installed the packages I downloaded from the ROS site. But when I try to launch the nodes again, I get the same rosbridge-error.

Do I have to do sth special with the self-implemented packages? Do I have to "install" them too?

DBServ gravatar imageDBServ ( 2018-02-07 00:44:20 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-02-06 09:14:23 -0500

Seen: 2,225 times

Last updated: Feb 07 '18