Ask Your Question
0

buildfarm: error while trying to run reconfigure script for master

asked 2018-02-06 03:50:00 -0500

tolliug gravatar image

Hello, I am trying to setup a build farm to build our software solution. However I have an error when I run

./reconfigure.bash master

Here's the output:

2018-02-06 10:46:56 +0100 Puppet (err): Evaluation Error: Error while evaluating a Function Call, Error from DataBinding 'hiera' while looking up 'ntp::autoupdate': (<unknown>): could not find expected ':' while scanning a simple key at line 34 column 1 at /root/buildfarm_deployment/modules/profile/manifests/ros/base.pp:8:3 on node ubuildfarm.

Does anyone have a clue about whats is going wrong and how to solve this?

edit retag flag offensive close merge delete

Comments

Something to check: no errors in your buildfarm_deployment_config yaml files? It's all valid yaml?

gvdhoorn gravatar image gvdhoorn  ( 2018-02-06 04:03:44 -0500 )edit

Sure something must be wrong but the error targets ntp services, so should I focused on timezone? I tried with America/Los_Angeles and Europe/Paris without any effect. So I don't know how to solve that and where to search for help

tolliug gravatar image tolliug  ( 2018-02-06 04:22:09 -0500 )edit

the error targets ntp services,

as with all parsers, I would say that the ntp class is just the first that happens to come across an error, and the parser prints that as an error. It doesn't mean the error is necessarily there.

so should I focused on timezone?

No, I don't believe so.

gvdhoorn gravatar image gvdhoorn  ( 2018-02-06 04:32:00 -0500 )edit

You could use something like adrienverge/yamllint to verify your yaml off-line.

But as I wrote, it's just a first thing to check.

gvdhoorn gravatar image gvdhoorn  ( 2018-02-06 04:32:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-02-07 00:32:55 -0500

nuclearsandwich gravatar image

updated 2018-02-07 02:16:34 -0500

gvdhoorn gravatar image

It definitely seems like something was unexpected in the hiera (yaml format) config data.

From the error message:

could not find expected ':' while scanning a simple key at line 34 column 1

would indicate a possible location, but it doesn't give a filename and it's possible that the position information refers to an intermediate converged file which is the result of merging the master and common hiera configurations. But I'd look at your configuration files.

To check YAML files, parsing them with the yamllint tool mentioned by @gvdhoorn works.

You can also use a language with an interactive interpreter to do a quick check. Ruby supports yaml parsing in the standard library. So checking looks a little like

$ irb
irb(main):001:0> require "yaml"
=> true
irb(main):002:0> YAML.load_file "hiera/hieradata/common.yaml"
=> {"jenkins::slave::ui_user"=>"admin", "jenkins::slave::ui_pass"=>"changeme", "jenkins::slave::masterurl"=>"http://master:8080", "master::ip"=>"172.30.1.145", "repo::ip"=>"172.30.1.69", "ssh_keys"=>{"ssh key comment / title"=>{"key"=>"AAAAB3NzaC1yc2EAAAADAQABAAABAQCXukygCeYbRCHP7IRxCIJpVTKYVtqIXRubANWVjGAQYEM+4FHca0ZCx/k+xOERj49ZIySXMOKdFlWELezYCnpJl6Q1qE2zPR4eSU/nEo9BwaCqbIrKoToND0L65goi4Ya/mKn3NBNkYJbAl+hHW0QQKhgyme5b1JgWZjkKX7b5eqzlkn0ic7hNUmRuj3gjJAvfvvMaVE0VIxnXSuw+SoxE8Q33qno4vtkxo8/6i1MpQgxB26e7UdeVY8xuUukByD0+pUARBMFlpOCu8ycMYcoMdJKiqVSRvn3/kg5lj39qro8kMwqR/m2nrTtZMiEfCNYSEuYNLjLUvRQbBGg8dxgp", "type"=>"ssh-rsa", "user"=>"root"}}, "autoreconfigure"=>false, "autoreconfigure::command"=>"bash -c \"cd /root/buildfarm_deployment_config && git fetch origin standalone-host && git reset --hard origin/standalone-host && ./reconfigure.bash\""}

With pyyaml installed you can do something similar with ipython.

edit flag offensive delete link more

Comments

@nuclearsandwich: this is not github, indent blocks with 4 spaces for verbatim formatting. Three backticks don't work.

gvdhoorn gravatar image gvdhoorn  ( 2018-02-07 02:17:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-06 03:50:00 -0500

Seen: 170 times

Last updated: Feb 07 '18