Ask Your Question
0

rosparam set not working

asked 2018-02-02 10:34:39 -0600

chanhyeoni gravatar image

I wanted to change the port for joystick driver from /dev/input/js0 to /dev/input/js1 using rosparam command.

rosparam set /joy_node/input "/dev/input/js1"

But after reboot, it changed back to js0. Any idea on why rosparam command does not permanently change the port?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-02 10:47:22 -0600

jayess gravatar image

First of all, how you're the first value is being set isn't disclosed in your question.

Second of all, according to a question that was answered about 2 hours ago (#q281646) parameters are not stored anywhere. Once rosmaster is shut down all of the parameters are gone. You have to reset the parameters every time you start rosmaster.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-02 10:34:39 -0600

Seen: 162 times

Last updated: Feb 02 '18