Ask Your Question
0

dwb_local_planner

asked 2018-01-30 12:13:41 -0500

BellocRosenblat gravatar image

updated 2018-02-06 16:05:46 -0500

jayess gravatar image

I am trying to implement the robot_navigation package into my robot. I clone the the entire robot_navigation folder into my catkin workspace and use catkin isolated make because when doing the regular catkin build it gives me a CMake Error "This workspace contains non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation....". The isolated build works, but when trying to run plan_node.launch in the dwb_local_planner/launch folder using roslaunch results in the error "ERROR: cannot launch node of type [dwb_local_planner/planner_node]: can't locate node [planner_node] in package [dwb_local_planner]. I have researched and everything I could find saying it wasn't sourced, but to my knowledge I did source it correctly. When running my other launch files in a separate folder it works correctly, but the terminal outputs the following:

[FATAL] [1517335343.278669007, 0.826000000]: Failed to create the dwb_local_planner/DWAPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: According to the loaded plugin descriptions the class dwb_local_planner/DWAPlannerROS with base class type nav_core::BaseLocalPlanner does not exist. Declared types are  base_local_planner/TrajectoryPlannerROS dwa_local_planner/DWAPlannerROS nav_core_adapter::LocalPlannerAdapter
[move_base-11] process has died [pid 28932, exit code 1, cmd /opt/ros/kinetic/lib/move_base/move_base cmd_vel:=/robot_diff_drive_controller/cmd_vel __name:=move_base __log:=/home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11.log].
log file: /home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11*.log

My question is if anyone knows why it isn't launching correctly?

edit retag flag offensive close merge delete

Comments

By robot_navigation, are you referring to the navigation meta-package? If so, why are you cloning the robot_navigation package directly into your workspace instead of installing it via $ sudo apt-get install ros-kinetic-navigation?

josephcoombe gravatar imagejosephcoombe ( 2018-01-30 13:05:47 -0500 )edit
1

There is no link, but I think the OP is referring to https://github.com/locusrobotics/robo... (which contains a dwb_local_planner package)

ahendrix gravatar imageahendrix ( 2018-01-30 13:12:45 -0500 )edit
1
BellocRosenblat gravatar imageBellocRosenblat ( 2018-01-30 13:15:31 -0500 )edit

this issue is similar, if you solve you can help or henoSH can help you.

rdelgadov gravatar imagerdelgadov ( 2018-01-30 13:33:38 -0500 )edit
2

This issue is likely resolved for you via https://github.com/locusrobotics/robo... . Pull from github again and try compiling again.

David Lu gravatar imageDavid Lu ( 2018-02-01 16:28:58 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-02-06 15:44:02 -0500

BellocRosenblat gravatar image

"This issue is likely resolved for you via https://github.com/locusrobotics/robo... ..Pull from github again and try compiling again. By. David Lu" This was resolved in the pull. Thanks for the assistance.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-30 12:13:41 -0500

Seen: 426 times

Last updated: Feb 06 '18