Ask Your Question
0

Launching ROS on startup

asked 2018-01-10 10:10:15 -0500

Amrello gravatar image

So I have oneboard computer with Ubuntu server andI want to start my nodes after startup automatically. So I tried to to add roslauch comand to rc.local and its not worked, than I find robot upstart package ( http://wiki.ros.org/robot_upstartand ) and roscore starts automatically, but not my nodes. Can anyone help me with this problem ?

edit retag flag offensive close merge delete

Comments

If you called robot_upstart on your Launch file, this should start. But all Launch files you want to start Need to be installed. If there is some HW-accesss from those nodes, another Problem could be that you don't have correct permissions for accessing the HW-ports (e.g. /dev/ttyUSB*) with ...

mgruhler gravatar image mgruhler  ( 2018-01-11 01:23:10 -0500 )edit

Robot_upstart and thus the node is crashing....

mgruhler gravatar image mgruhler  ( 2018-01-11 01:23:22 -0500 )edit

Thanks for advice

Amrello gravatar image Amrello  ( 2018-01-11 02:46:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-11 02:58:05 -0500

Amrello gravatar image

I solved this problem. In my node I use serial communication with microcontroller so node can't open serial port and crushed. In general here's what I did that I did:

sudo nano /etc/rc.local

and add

chmod 666 /dev/ttyS1

to change attributes, ttyS1 my serial port

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-01-10 10:10:15 -0500

Seen: 716 times

Last updated: Jan 11 '18